Issue on installing anki 2.1 for ubuntu xenial (16.04) armfh

Sonkei's Avatar

Sonkei

30 Jan, 2020 04:44 PM

Hello everyone,

I am currently stuck with a ubuntu xenial (16.04) environnement on armhf architecture, with only Anki 2.0.32 available on this plateform.
Since Anki 2.0 is sunsetting soon, I’m looking for a solution to get Anki 2.1 running on my ubuntu phone (hence the weird environnement).

I tried to install it with the 2.1.15-alternate package provided, but it’s compiled for amd64 architecture.
I tried to build it from the sources but qt5 is in version 5.5, far from the 5.9 required (and I haven’t found a way to install it in armhf without the GUI interface).
Likewise, trying to get anki 2.1 from the bionic repository end up in failure because of the missing python3-qt5 packages.

Do you have any ideas about how I could get my hand on a anki 2.1 alternate build for arm architecture ? (it seems to be the easiest way…)

Thank you in advance

  1. 1 Posted by Sonkei on 24 Feb, 2020 06:46 AM

    Sonkei's Avatar

    I made some progress since then:
    UBPorts has Qt 5.9.5 available in the repository. So starting from there, I installed sip-4.19.14 from the sources, and then PyQt-5.9.1 from the sources.
    Since a lot of modules where missing for the compilation of PyQt, I had to install the following packages :
    * libqt5qml5 * qtwebengine5-dev And then build PyQt from the sources (python3 --configure --verbose, and then make).
    I also installed a python3.6 from the deadsneakes ppa, and changed the link of python3 to python3.6.

    With all this I had Anki running, only showing the sync bar in full screen and then shut down (if not in infinite loop on the sync).
    I don't have much information from the logs. Do you know where I can find more information from my system ?

    Thank you in advance,

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac