DeprecationWarning: Call to deprecated create function EnumValueDescriptor()

addons_zz's Avatar

addons_zz

03 Jun, 2020 05:55 PM

I am seeing these warnings on my computer when I run make check. Perhaps you should update the code?

F:\anki\pylib\anki\fluent_pb2.py:419: DeprecationWarning: Call to deprecated create function EnumValueDescriptor(). Note: Create unlinked descriptors is going to go away. Please use get/find descriptors from generated code or query the descriptor_pool.
_descriptor.EnumValueDescriptor(
  1. Support Staff 1 Posted by Damien Elmes on 04 Jun, 2020 10:59 AM

    Damien Elmes's Avatar

    Maybe your protobuf binary, or python-protobuf library in pyenv need updating?

  2. 2 Posted by addons_zz on 04 Jun, 2020 05:09 PM

    addons_zz's Avatar

    I was using libprotoc 3.11.4 but after installing the latest version libprotoc 3.12.3: https://github.com/protocolbuffers/protobuf/releases and looks like that message is gone now.

Comments are closed, but you can start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac