Error loading collection

marreromarco's Avatar


01 Apr, 2020 09:26 AM

This comment was split from the discussion: Anki 2.1.24 Beta

Upgraded to latest Anki 2.1.24 (d3964603).

HeatMap was disabled and Anki worked OK. After enabling it, Anki fails to start even if I press Shift while starting Anki to disable all add ons.

I am using Linux Mint 19.3 XFCE

An error occurred. Please use Tools > Check Database to see if that fixes the problem.
If problems persist, please report the problem on our support site. Please copy and paste the information below into your report.
Anki 2.1.24 (d3964603) Python 3.8.1 Qt 5.14.1 PyQt 5.14.1
Platform: Linux
Flags: frz=True ao=False sv=2
Add-ons, last update check: 2020-04-01 12:49:12

Traceback (most recent call last):
File "aqt/", line 468, in loadCollection File "aqt/", line 604, in moveToState File "aqt/", line 611, in _deckBrowserState File "aqt/", line 54, in show File "aqt/", line 109, in _renderPage File "anki/", line 275, in deckDueTree File "anki/", line 253, in deckDueList File "anki/", line 478, in _deckNewLimitSingle File "anki/", line 369, in confForDid TypeError: 'NoneType' object does not support item assignment

  1. Support Staff 1 Posted by Damien Elmes on 01 Apr, 2020 09:31 AM

    Damien Elmes's Avatar

    If you hit esc to close the error and run the following in the debug console, it should fix it for now:

    for d in mw.col.decks.decks.values():
      if isinstance(d['conf'], str):
        d['conf'] = int(d['conf'])

  2. 2 Posted by marreromarco on 01 May, 2020 03:57 AM

    marreromarco's Avatar

    Solved! Thanks !

Comments are closed, but you can start a new discussion.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac