Linux build with new toolkit version

Damien Elmes's Avatar

Damien Elmes

28 Oct, 2018 12:56 AM

Hi all,

I've uploaded a build of Anki with the latest toolkit version (Qt 5.12 Beta 2). Please give it a try and let me know of any improvements or regressions you notice.

The new build requires a Linux distribution from around 2016 or later.

In addition to the toolkit changes, this build changes the undo shortcut back to Ctrl+Z, and includes support for the fcitx input method.

Known issues:

  • Your window sizes and sync login details will be reset when moving back to a previous 2.1.x version.
  • Japanese/Chinese IME typed text is difficult to see until enter is pressed.

Download link:

https://apps.ankiweb.net/downloads/beta/

  1. 1 Posted by Andrea on 28 Oct, 2018 03:57 AM

    Andrea's Avatar

    It worked!
    Thank you very much indeed! :)

  2. 2 Posted by danlei on 28 Oct, 2018 05:19 PM

    danlei's Avatar

    As mentioned in the other thread, this fixes the issue of the missing charts on the statistics page.

    And thank you very much for reverting the undo shortcut and working on fcitx. While it mostly worked out of the box for me, there is still an issue in the browser's card fields: The input is just a black bar until I press return. (It works perfectly in the search bar, though.)

    However, this version seems to have messed up the order of my unseen cards somehow. I don't have much time right now, but I'll get back to you later if you need further details.

    (Also, there is a pretty noticeable performance hit, but that might be due to some debugging stuff going on, I assume.)

  3. 3 Posted by julian-anki on 28 Oct, 2018 07:57 PM

    julian-anki's Avatar

    Hi Damien,

    I built it against Qt 5.11.2 on Debian, and it works perfectly, thank you!

  4. 4 Posted by danlei on 28 Oct, 2018 09:40 PM

    danlei's Avatar

    Ok, I've checked my backups and the card order problem is unrelated. I seem to have messed something up earlier without recognizing it. (And I have missed the known issues part.)

    So, everything is fine — just little on the slow side.

    Thanks again!

  5. 5 Posted by Tomek on 02 Nov, 2018 11:01 AM

    Tomek's Avatar

    Japanese work fine, but when I write I can't see what I write. When I typing instead of kana I see black bar. I use Manjaro and fcitx with anthy.

  6. Damien Elmes closed this discussion on 13 Nov, 2018 04:58 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac