iOS Anki 2.0.53 "Problem" shows a delay, iPhone 11

Jeff's Avatar

Jeff

21 Oct, 2019 02:40 AM

iOS Anki 2.0.53 "Question" shows a delay (not "Anser"), iPhone 11 iOS 13.1.3, it feels like there is a 1 second animation, fade in and out. Can this feature be turned off? Because every time I have to review thousands of cards, the speed is very fast, and the delay makes my eyes feel uncomfortable.

  1. Support Staff 1 Posted by Damien Elmes on 21 Oct, 2019 10:24 PM

    Damien Elmes's Avatar

    The question fade in is 100ms, like the computer version. If you want to reduce it or turn it off, you can put the following in your card template:

    Edit: see below.

  2. 2 Posted by Jeff on 22 Oct, 2019 01:56 AM

    Jeff's Avatar

    It works! Thank you for your patience.

    I found this forum has a lot of help information about anki, but Google can't index. Because the robots configuration of "https://anki.tenderapp.com/robots.txt" prohibits crawlers, it may be that the webmaster has set privacy considerations.

    Maybe later, can add a section to turn off animation effects in "https://apps.ankiweb.net/docs/manual.html#basic-templates":
    {{FrontSide}}

    <hr id=answer>

    {{Back}}

    Edit: see below.

  3. Support Staff 3 Posted by Damien Elmes on 22 Oct, 2019 10:52 PM

    Damien Elmes's Avatar
  4. 4 Posted by Ken on 25 Oct, 2019 09:20 PM

    Ken's Avatar

    Is there another way to turn off this fade on mobile without editing every card? I use premade decks with so going thru each card is not feasible.

    I have an addon on desktop to remove this fade.

  5. Support Staff 5 Posted by Damien Elmes on 25 Oct, 2019 11:47 PM

    Damien Elmes's Avatar

    Changing the card template will affect all cards that use the template, and once any of those cards are shown, the setting will stick for the remainder of the study session.

  6. 6 Posted by M on 26 Oct, 2019 02:41 PM

    M's Avatar

    This is an inconvenient step for decks that have many different card types.

    I would think that fading would be a system-wide preference anyway, rather than a template-specific preference.

    Accordingly, would it be possible to have the fade editable from Settings/Review?

  7. Support Staff 7 Posted by Damien Elmes on 26 Oct, 2019 11:19 PM

    Damien Elmes's Avatar

    You can run the following in the debug console to disable fading on all templates:

    mw.col.conf['reviewExtra']="<script>qFade=0; if (typeof anki !== 'undefined') anki.qFade=qFade;</script>"
    mw.col.setMod()
    

    https://apps.ankiweb.net/docs/manual.html#debug-console

  8. 8 Posted by M on 30 Oct, 2019 10:09 PM

    M's Avatar

    Works perfectly. Thanks!!

  9. 9 Posted by Ryan Rivera on 16 Jun, 2020 02:57 AM

    Ryan Rivera's Avatar

    Thanks for the system-wide fix. Waiting for the fade animation was wasting 100 seconds for every 1000 reviews, plus it was upsetting me because I’m impatient like that.

  10. 10 Posted by samir.yep on 16 Jun, 2020 02:21 PM

    samir.yep's Avatar

    After applying the debug console code, the fade animation is gone from the ios app but there is now a huge 7 second delay (not fade) in playing audio on macos anki. Is there a way to reverse the debug console code?

  11. 11 Posted by samir.yep on 16 Jun, 2020 02:29 PM

    samir.yep's Avatar

    No worries. I managed to overcome this by entering qFade=1

Comments are closed, but you can start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac