anki continues to repeatedly crash

princeofnam's Avatar

princeofnam

26 Jun, 2014 04:10 AM

Since updating to the newest version of Anki on linux I've noticed that it will unexpectedly crash. What's weird is that it doesn't do so in the standard fashion most software crashes in Kubuntu. It doesn't freeze at all. The program instantly disappears and there's no request from linux to send a bug report. I was curious to see if I could figure out more about what was going on so I opened Anki via the terminal and gave me back a rather bland error.

"Segmentation fault (core dumped)"

Does anyone know what that might mean?

  1. 1 Posted by Soren Bjornstad on 26 Jun, 2014 01:22 PM

    Soren Bjornstad's Avatar

    A segmentation fault means that some part of Anki tried to access a part of memory that it didn't have access to and the operating system shut it down immediately (the error comes from the operating system, which is why it crashes in a different manner than usual).

    However, as you said, that's not a very helpful error, since there are lots of possible causes. Are you doing something in particular before it starts happening? When you say the 'newest version,' are you on the beta or the latest stable version? I'm on Linux Mint and was having some occasional problems earlier, but in the latest couple of versions they've gone away.

  2. 2 Posted by princeofnam on 26 Jun, 2014 02:44 PM

    princeofnam's Avatar

    I'm running 2.0.26. I believe that's the latest stable version. The last time it quit on me I had just hit spacebar to turn over a card. Pretty unremarkable. Btw I'm running Kubuntu 14.04

  3. 3 Posted by Soren Bjornstad on 26 Jun, 2014 05:03 PM

    Soren Bjornstad's Avatar

    Would you mind trying to get a backtrace for us so we can see what's going on? You can do so using the GNU debugger gdb as follows:

    1. Run gdb in a terminal. If you don't have gdb installed yet, it's in the package of the same name (sudo apt-get install gdb to install). This should give you a (gdb) prompt.
    2. Run the command file python at the gdb prompt. You should get a line telling you it's 'reading symbols'.
    3. Run the command run anki at the gdb prompt. If you get an error saying it can't find Anki, you may need to use the full path. If you don't know it, you can run whereis Anki in a new terminal and then try running each of those in sequence (e.g., /usr/bin/anki) and seeing which one starts Anki.
    4. Anki will start. Use it normally until it crashes again.
    5. Run bt at the gdb prompt, and copy and paste the output of that backtrace. Please enclose the output in triple @ signs on separate lines at the top and bottom to be sure TenderApp doesn't try to parse it as HTML.
    6. When you're done, you can exit gdb by pressing Control-D or with the command quit.
  4. 4 Posted by princeofnam on 26 Jun, 2014 10:03 PM

    princeofnam's Avatar

    It crashed again. Oddly uder gdb it would crash the conventional way by simply freezing. Anyway when I tried to collect the log by typing in "bt" i got the following error

    #0  0x00007ffff5a4e73e in ?? () from /usr/lib/python2.7/dist-packages/sip.so
    Cannot access memory at address 0x7fffffffce68
    (gdb)
    

    I apologize if this is turning more into a linux support thread.

  5. 5 Posted by Soren Bjornstad on 26 Jun, 2014 11:09 PM

    Soren Bjornstad's Avatar

    I'm afraid this looks like a bug with the toolkit and its interaction with Ubuntu, and not anything we can fix. If you're continuing to have problems, please try the Kubuntu forums and community and see if they can help.

  6. 6 Posted by princeofnam on 26 Jun, 2014 11:14 PM

    princeofnam's Avatar

    gotcha. thanks for getting me closer to a solution though.

  7. 7 Posted by Soren Bjornstad on 27 Jun, 2014 02:38 AM

    Soren Bjornstad's Avatar

    You're welcome, and please let us know if you have other issues we can be more helpful on. :)

  8. Soren Bjornstad closed this discussion on 27 Jun, 2014 02:38 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac