How to strip formatting when pasting

ankiforme's Avatar

ankiforme

17 Jun, 2020 03:36 PM

I'm running Anki Version 2.1.23 (de9543ff).

When pasting text, I automatically have formatting included as shown below.

"事態の打開 a Click+Drag:
(Left⇔Right)
Resize with aspect ratio.

Ctrl+Click+Drag:
Resize freely.

Shift+Click:
Restore original size.breakthrough [new development] in the situation."

instead of...

"事態の打開 a breakthrough [new development] in the situation." (by the way, copy and pasting this into this text box stripped that formatting; that's what I want but just in Anki.

Please help.

  1. Support Staff 1 Posted by Damien Elmes on 18 Jun, 2020 11:43 PM

    Damien Elmes's Avatar

    Hi,

    You can either hold down shift, or change the option in the preferences.

  2. 2 Posted by ankiforme on 19 Jun, 2020 02:36 PM

    ankiforme's Avatar

    On a MacBook, by the way.

    Holding down shift doesn't get rid of it*.

    And, if you're referring to "Paste without shift key strips formatting," then it doesn't matter whether or not that box is checked, still doesn't get rid of it*.

    Strange.

    Note: "IT" being

    "a Click+Drag:
    (Left⇔Right)
    Resize with aspect ratio.

    Ctrl+Click+Drag:
    Resize freely.

    Shift+Click:"

  3. Support Staff 3 Posted by Damien Elmes on 19 Jun, 2020 11:54 PM

    Damien Elmes's Avatar

    Ah, I see what you mean. Recent Anki versions preserve newlines even when stripping formatting. I'm afraid there is no setting to control this, but I will keep an eye on demand for the old behaviour.

  4. 4 Posted by ankiforme on 21 Jun, 2020 01:12 AM

    ankiforme's Avatar

    Thank you.
    Guess I can try upgrading.

  5. ankiforme closed this discussion on 21 Jun, 2020 01:12 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac