Network Error

nihongoacquirer's Avatar

nihongoacquirer

30 May, 2020 01:49 PM

Every time I try to open Anki from my computer's mac partition I get this error message saying "error sending request for url (): error trying to connect: The trust policy was not trusted.⁩" This error appears every time I do some activity that would call for synchronization. However, this wasn't happening at all yesterday when I was doing my daily reps. Also, when I try to access Anki through Windows or the online website, there is no issue. I've attached a screenshot of the full error. I couldn't find any preexisting discussion about this, but this is my first time trying to use this website so I could just be missing it. Is there anything I can do to fix this problem?

  1. 1 Posted by nihongoacquirer on 30 May, 2020 03:30 PM

    nihongoacquirer's Avatar

    Another aspect that seems worth mentioning is that, although I get this error, I am still able to perfectly sync progress that I make on my mac partition to the rest of my devices. Also when I try closing the app again that error pops up again, and I am need to force quit Anki to make it actually close.
    edit: Actually it seems as though I am not properly downloading the audio and pictures I used for cards that I had made on another device. It seems as though that particular part of the syncing is going wrong while everything else is fine.

  2. 2 Posted by addons_zz on 30 May, 2020 06:50 PM

    addons_zz's Avatar

    Try to update to the latest Anki version from https://apps.ankiweb.net/

    Please, see also When problems occur

  3. 3 Posted by nihongoacquirer on 30 May, 2020 07:43 PM

    nihongoacquirer's Avatar

    Yeah I check that page and did everything it said to no avail. I have the 2.1.23-alternate, which should be the most up to date stable release. This error happened out of nowhere after continual proper functioning, so I'm not particularly inclined to blame it on out of date software.

  4. 4 Posted by addons_zz on 30 May, 2020 08:28 PM

    addons_zz's Avatar

    The latest stable version of Anki version is 2.1.26

  5. 5 Posted by awhiteguy on 30 May, 2020 10:33 PM

    awhiteguy's Avatar

    Began having this same exact issue today. Running 2.1.23 on Mac. May try updating sw, but 2.1.23 should still be supported. Since both of us started having this issue today, i would guess there were changes made on the server side causing the syncing issue.

  6. 6 Posted by Shane on 31 May, 2020 12:30 AM

    Shane's Avatar

    also getting the exact same issues today

  7. 7 Posted by andreas.luber53 on 31 May, 2020 04:29 AM

    andreas.luber53's Avatar

    Same issue here, since a couple of days. Using the latest Anki build. Error occurs with Chrome as well as Firefox, even IE.

    I believe the certificate of AnkiWeb is outdated, which is why all browsers prevent access for security reasons.

    Error messag as provided by Chrome:

    Your connection is not private
    Attackers might be trying to steal your information from ankiweb.net (for example, passwords, messages, or credit cards). Learn more
    NET::ERR_CERT_COMMON_NAME_INVALID
    Subject: irealone.com

    Issuer: Let's Encrypt Authority X3

    Expires on: Jul 25, 2020

    Current date: May 31, 2020

  8. Support Staff 8 Posted by Damien Elmes on 31 May, 2020 11:23 PM

    Damien Elmes's Avatar

    An upstream SSL cert expired. I've updated AnkiWeb's cert bundle which should fix the problem on older machines.

    Andreas: yours is a different issue, and I've replied on your other post.

  9. 9 Posted by nihongoacquirer on 01 Jun, 2020 02:32 PM

    nihongoacquirer's Avatar

    Damien I'm still experiencing the issue. Should I expect some delay before the problem is fixed? My device is running OSX Yosemite if that helps.

  10. 10 Posted by Farah on 02 Jun, 2020 12:58 AM

    Farah's Avatar

    I am also running into the same problem as nihongoacquirer. Syncing the cards but no syncing media (I double checked on Ankiweb as well, it said media was missing). Running Yosemite as well.

  11. 11 Posted by Dan on 02 Jun, 2020 03:09 AM

    Dan's Avatar

    Similar issue on windows

    Cards could be synced but media couldn't. The issue starts on Jun 1 here and persists up to now.

  12. 12 Posted by andreas.luber53 on 02 Jun, 2020 04:53 AM

    andreas.luber53's Avatar

    Damian,

    thanks for looking at it.

    Unfortunately, the web server you are using to serve https://ankiweb.net
    (88.99.70.72) is still providing an outdated SSL certificate. According to
    the certificate itself, you / your team seem to have gotten the
    certificate from irealone.com, interestingly it was valid only from
    26.04.2020 to 25.07.2020 - if that helps.

    Not sure which SSL certificates you have updated, however, ankiweb.net is
    still providing an outdated one, making it's usage impossible.

    Please note: I kind of disagree with your analysis, that the problem comes
    down to my machine. As the web server hosting ankiweb.net is providing
    outdated information, this seems to be the root of the problem. Ankiweb.net
    is the only web site of reporting this error - making your suggestion f
    malware issues rather unlikely.

    Have a great one!

    Andreas

    Am Mo., 1. Juni 2020 um 01:23 Uhr schrieb Damien Elmes <
    [email blocked]>:

  13. 13 Posted by Dan on 02 Jun, 2020 05:14 AM

    Dan's Avatar

    @andreas

    might be something wrong with your network.

    The certificate is not outdated and provider is Sectigo

  14. Support Staff 14 Posted by Damien Elmes on 02 Jun, 2020 10:17 AM

    Damien Elmes's Avatar

    Yosemite users: your problem should now be fixed

    Dan: you appear to have a different issue, please see my reply to your other ticket

  15. Support Staff 15 Posted by Damien Elmes on 02 Jun, 2020 10:19 AM

    Damien Elmes's Avatar

    Andreas: that IP is not associated with AnkiWeb - if your DNS server gave you that IP then your DNS server is broken

  16. 16 Posted by andreas.luber53 on 02 Jun, 2020 12:07 PM

    andreas.luber53's Avatar

    Damian,
    Indeed, that has been the cause. After DNS resolution got fixed, my problem
    is gone.
    Thanks for your help!
    Regards,
    Andreas

    Damien Elmes <[email blocked]> schrieb am Di., 2. Juni
    2020, 12:19:

  17. 17 Posted by Farah Khan on 02 Jun, 2020 01:57 PM

    Farah Khan's Avatar

    Hi Damien, just letting you know it does appear to be working on my
    computer (running Yosemite) now. Thank you so much for your help!

  18. 18 Posted by nihongoacquirer on 03 Jun, 2020 02:59 PM

    nihongoacquirer's Avatar

    Yeah my problem is fixed now. Thanks for the help.

Comments are closed, but you can start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac