Computer chimes every time I click on the Anki "record audio" icon

Steven's Avatar

Steven

11 Mar, 2020 06:31 PM

Hello,

Anki 2.1.21 on Windows 10 64-bit 1909

Every time I click on the microphone icon (Record audio) in Anki, my computer "chimes". This happens in the Browser and in the Add screen. The Anki "Recording..." dialog pops up, records correctly and saves automatically—all that works—but there is an audio chime as the dialog pops up (which is recorded by the mic.)

If I click on the record button in another app, Audacity for example, things work normally: the computer doesn't chime.

Any ideas?

Thank you for your assistance,

Steven

  1. Support Staff 1 Posted by Damien Elmes on 12 Mar, 2020 11:14 AM

    Damien Elmes's Avatar

    Hi Steven,

    I've seen one other user report this, but can't seem to reproduce it here. If you search for "change system sounds" in the start bar, and test the "Device Connect" sound, is that the sound you are hearing? If not, does one of the others there match?

  2. 2 Posted by Steven on 20 Mar, 2020 04:54 PM

    Steven's Avatar

    Hello!

    Thanks for your reply. I went to the Windows "Sounds" configuration, and
    found that the chime I am hearing each time I click on the "record" icon in
    Anki is "Windows Background.wav". I went through the list of Program Events
    and found that "Windows Background.wav" is associated with 5 different
    Program Events. When I set the "Asterisk" event to "None", my computer no
    longer chimes when I click on Anki's record icon. (Setting the other events
    to "None" doesn't help.)

    I hope this information will help diagnose the problem.

    Also, before setting Asterisk to "None", I tried upgrading to Anki 2.1.22,
    but that didn't make any difference.

    Thanks again.

    Cheers,

    Steven

  3. Support Staff 3 Posted by Damien Elmes on 22 Mar, 2020 11:43 AM

    Damien Elmes's Avatar

    Thanks for looking into that. I am guessing that the toolkit Anki uses has decided it should play a sound when a dialog is presented when it didn't before. I'm not sure if that is something I have control over or not - turning off that sound in the Windows settings should work around the issue for now.

  4. 4 Posted by nograe on 22 Apr, 2020 01:43 AM

    nograe's Avatar

    I had the same problem and also "fixed" it by setting "Asterisk" to "None." But, that makes me wonder what other chimes on my computer could be affected that might be important but that I am no longer hearing. I think this is a problem that should be addressed.

  5. 5 Posted by elbasut on 08 May, 2020 07:25 PM

    elbasut's Avatar

    I had the same problem. Also managed to "fix" it by doing what Steven did. So thanks for the tip!

  6. 6 Posted by Tartarin on 27 May, 2020 10:36 PM

    Tartarin's Avatar

    Same for me, on windows 8.1. Before that, I had an older version of Anki (2.0.something), the problem wasn't there.
    The workaround worked.

Comments are closed, but you can start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac