Cannot search for round brackets

lilalas's Avatar

lilalas

10 Mar, 2020 11:06 PM

I have a large deck where some notes contain round brackets in the text field. Now I want to systematically change those cards; so I tried to search for the character ( in my deck. Unfortunately, this does not seem to be possible.

When I search for deck:current (, I get zero results. deck:current "(" will not do good either.

I have tested this on PC (version 2.1.20) and AnkiMobile (version 2.0.59) with identical (negative) results.

I have also found an old thread describing basically exactly the same problem. Unfortunately, that one got closed due to inactivity and I am not permitted to post there.

  1. 1 Posted by lilalas on 10 Mar, 2020 11:07 PM

    lilalas's Avatar

    You would assume implementing a fix for this should take less then five years; maybe it has indeed been forgotten ;p

  2. Support Staff 2 Posted by Damien Elmes on 11 Mar, 2020 05:24 AM

    Damien Elmes's Avatar

    There are only so many hours in the day, so issues that affect a lot of people tend to take priority I'm afraid. One workaround you could use is to use the Find&Replace feature to replace them with something else, then search for that.

  3. 3 Posted by lilalas on 11 Mar, 2020 10:57 AM

    lilalas's Avatar

    Good thinking! I suppose this is an acceptable workaround. Albeit a bit tedious, it worked just fine in my case. Thank you for your help!

  4. 4 Posted by lilalas on 11 Mar, 2020 11:07 AM

    lilalas's Avatar

    Please let me suggest a possibly cheap way to implement a fix: Make the Search tool behave similar to the Find & Replace tool, in that there is a setting/checkbox to choose whether you want to use regular expressions or not.

  5. Support Staff 5 Posted by Damien Elmes on 12 Mar, 2020 10:37 AM

    Damien Elmes's Avatar

    That won't help, it's an issue with the parsing of the search terms. I'll fix it when I have a chance :-)

Comments are closed, but you can start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac