Anki won't start, "cannot create data folder"

hakanai_mia's Avatar

hakanai_mia

19 Jan, 2020 09:47 PM

keep getting the same error message. I've tried everything I can think of (restart, reinstall, clean reinstall, different versions, full windows updates, changing permissions on folder.......)

here's the log from cmd

C:\Windows\system32>cd \program files\anki

C:\Program Files\Anki>anki-console
[4748] PyInstaller Bootloader 3.x
[4748] LOADER: executable is C:\Program Files\Anki\anki-console.exe
[4748] LOADER: homepath is C:\Program Files\Anki
[4748] LOADER: _MEIPASS2 is NULL
[4748] LOADER: archivename is C:\Program Files\Anki\anki-console.exe
[4748] LOADER: C:\Program Files\Anki\anki-console.exe contains a digital signatu
re
[4748] LOADER: No need to extract files to run; setting extractionpath to homepa
th
[4748] LOADER: SetDllDirectory(C:\Program Files\Anki)
[4748] LOADER: Already in the child - running user's code.
[4748] LOADER: Python library: C:\Program Files\Anki\python36.dll
[4748] LOADER: Loaded functions from Python library.
[4748] LOADER: Manipulating environment (sys.path, sys.prefix)
[4748] LOADER: sys.prefix is C:\Program Files\Anki
[4748] LOADER: Pre-init sys.path is C:\Program Files\Anki\base_library.zip;C:\Pr
ogram Files\Anki
[4748] LOADER: Setting runtime options
[4748] LOADER: Initializing python
[4748] LOADER: Overriding Python's sys.path
[4748] LOADER: Post-init sys.path is C:\Program Files\Anki\base_library.zip;C:\P
rogram Files\Anki
[4748] LOADER: Setting sys.argv
[4748] LOADER: setting sys._MEIPASS
[4748] LOADER: importing modules from CArchive
[4748] LOADER: extracted struct
[4748] LOADER: callfunction returned...
[4748] LOADER: extracted pyimod01_os_path
[4748] LOADER: callfunction returned...
[4748] LOADER: extracted pyimod02_archive
[4748] LOADER: callfunction returned...
[4748] LOADER: extracted pyimod03_importers
[4748] LOADER: callfunction returned...
[4748] LOADER: Installing PYZ archive with Python modules.
[4748] LOADER: PYZ archive: PYZ-00.pyz
[4748] LOADER: Running pyiboot01_bootstrap.py
[4748] LOADER: Running pyi_rth_win32comgenpy.py
[4748] LOADER: Running pyi_rth_pyqt5webengine.py
[4748] LOADER: Running pyi_rth_pyqt5.py
[4748] LOADER: Running pyi_rth_multiprocessing.py
[4748] LOADER: Running pyi_rth_pkgres.py
[4748] LOADER: Running runanki.py
Traceback (most recent call last):
  File "aqt\__init__.py", line 276, in run
  File "aqt\__init__.py", line 303, in _run
  File "aqt\profiles.py", line 69, in __init__
  File "aqt\profiles.py", line 285, in _setBaseFolder
  File "aqt\profiles.py", line 121, in maybeMigrateFolder
  File "aqt\profiles.py", line 113, in _oldFolderLocation
  File "aqt\winpaths.py", line 142, in get_personal
  File "aqt\winpaths.py", line 97, in _get_path_buf
  File "aqt\winpaths.py", line 86, in _err_unless_zero
aqt.winpaths.WinPathsException: Failed to retrieve windows path: -2147024893
QWidget: Must construct a QApplication before a QWidget

  1. Support Staff 1 Posted by Damien Elmes on 19 Jan, 2020 10:48 PM

    Damien Elmes's Avatar
  2. Support Staff 2 Posted by Damien Elmes on 19 Jan, 2020 10:49 PM

    Damien Elmes's Avatar

    Sorry, private link. The relevant part:

    Your system seems to have CSIDL_PERSONAL / My Documents pointing to an invalid path.

    A brief Google surfaces the following: http://support.legacyfamilytree.com/article/AA-00863/0/System-call-...

  3. 3 Posted by hakanai_mia on 20 Jan, 2020 10:00 AM

    hakanai_mia's Avatar

    amazing! the solution you linked to worked. I wonder how that got messed up...

    thank you Damien for an incredible app and your rapid-response support! all the best

Comments are closed, but you can start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac