Error upgrading to 2.1.18 on linux, now unable to access all decks

HD's Avatar

HD

14 Jan, 2020 06:56 PM

hi there I downloaded and ran make on anki-2.1.18-linux-amd64 and installation seemingly terminated successfully ("Install complete. Type 'anki' to run", and with new binary at /usr/local/bin/anki.
However running anki yielded this

$ /t/m/anki-2.1.18-linux-amd64> anki
Traceback (most recent call last):
  File "runanki", line 3, in <module>
  File "/home/dae/Local/py514/lib/python3.8/site-packages/PyInstaller-4.0.dev0+g2886519-py3.8.egg/PyInstaller/loader/pyimod03_importers.py", line 625, in exec_module
  File "aqt/__init__.py", line 21, in <module>
  File "/home/dae/Local/py514/lib/python3.8/site-packages/PyInstaller-4.0.dev0+g2886519-py3.8.egg/PyInstaller/loader/pyimod03_importers.py", line 625, in exec_module
  File "aqt/qt.py", line 15, in <module>
ImportError: libsystemd.so.0: cannot open shared object file: No such file or directory
[12570] Failed to execute script runanki

I'm running linux mint 17.1 Mate on a 64-bit processor

  1. Support Staff 1 Posted by Damien Elmes on 14 Jan, 2020 10:28 PM

    Damien Elmes's Avatar

    Hi HD,

    Your system doesn't appear to support systemd, which means you'll need to download the alternate version from Anki's download site.

  2. 2 Posted by blaxwhix on 15 Jan, 2020 10:57 PM

    blaxwhix's Avatar

    HD,

    I suggest you may want to upgrade it to 19.3 Mint. As Damien mention, you will need to download the older version of Anki(2.1.16).
    If you would like to use 2.1.18, you want to upgrade to Linux Mint 19.3.

Comments are closed, but you can start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac