I can't update Anki.

André Carlos's Avatar

André Carlos

02 Dec, 2019 08:27 PM

I upgraded from Anki 2.0 to 2.1.15 (windows 10 - 64bits), but when trying to start the program the following message appears:
Anki's prefs21.db file was corrupt and has been recreated. If you were using multiple profiles, please add them back using the same names to recover your cards.

I uninstalled and installed several times.
I restarted the PC several times.
I searched prefs21.db and prefs.db to rename it, but it doesn't have.
I deleted my decks from the old version.
I used programs for complete uninstallation.
I do not use extensions and already tried to start by pressing "shift".
I tried other versions, even Beta.
Nothing worked, I can not even enter the program, because only the message above appears.

Please help me. Thanks for listening.

  1. Support Staff 1 Posted by Damien Elmes on 02 Dec, 2019 08:59 PM

    Damien Elmes's Avatar

    You can locate the prefs files in your Anki data folder, and renaming them will likely fix the problem: https://apps.ankiweb.net/docs/manual.html#file-locations

  2. 2 Posted by André Carlos on 02 Dec, 2019 10:50 PM

    André Carlos's Avatar

    Thank you very much, it worked! :)

  3. 3 Posted by joorek on 14 Dec, 2019 06:47 AM

    joorek's Avatar

    I have another problem. I have downloaded the new version of Anki 2.1.15, but every time I finish installing and I open Anki it shows the old 2.0.51 version. I tried to uninstall the old version and install the new one, but the effect is always the same

  4. 4 Posted by geoffF on 14 Dec, 2019 07:16 AM

    geoffF's Avatar

    I have tried updating anki to version 2.1.15 , it seems to install ok but when I run it I get the error message LoadLibrary failed with error 1114: a dynamic link library (dll) initialization routine failed

    I have tried all the usual uninstall, restarting etc with no luck, any suggestions?

    cheers, geoffF

  5. Support Staff 5 Posted by Damien Elmes on 14 Dec, 2019 10:10 PM

    Damien Elmes's Avatar

    You'll need to replace 'auto' with 'angle' in the video driver section:


  6. 6 Posted by geoffrey.fillin... on 16 Dec, 2019 09:09 AM

    geoffrey.fillingham's Avatar

    Thanks for the prompt help Damien, It works now

    Cheers, geoffF

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac