Anki 2.1 doesn't start

Andreas's Avatar

Andreas

14 Nov, 2019 08:32 AM

Hallo,

thanks for your great software. Sorry if I ask a question which was asked before but in my searching I did not find something what solves my problem.

I had anki 2.0 and it worked fine. After receiving the message to update to 2.1 because of sync. I updated it.

I click on the icon and nothing happen. I tried to check in the task manager is there any answer but I did not see anything related to anki after clicking the anki icon.

I tried to follow the instructions for the windows updates but these updates were not longer available for windows 7. I don't know why.
Anyway, do you have an idea what I can do to solve the problem? So far my windows is update up to date.

  1. Support Staff 1 Posted by Damien Elmes on 14 Nov, 2019 09:16 AM

    Damien Elmes's Avatar

    You could try the -alternate version on the download site, and try renaming your data folder: https://apps.ankiweb.net/docs/manual.html#file-locations

  2. 2 Posted by Andreas on 14 Nov, 2019 09:57 AM

    Andreas's Avatar

    I installed the alternate version. Before I tried also the 64 bit version but I did get a warning that it is not matching. My windows is in 32 bit.
    I did not see or understand which file I have to rename from the link.

  3. Support Staff 3 Posted by Damien Elmes on 14 Nov, 2019 08:24 PM

    Damien Elmes's Avatar

    I was suggesting renaming the entire Anki2 folder, but on second thought, please try these debugging steps first: https://anki.tenderapp.com/discussions/beta-testing/25-209-beta-win...

  4. 4 Posted by Andreas on 14 Nov, 2019 09:36 PM

    Andreas's Avatar

    First, thanks for your support.

    Sadly it's still not working but you can check my processes here...

  5. 5 Posted by Andreas on 14 Nov, 2019 09:55 PM

    Andreas's Avatar

    Sorry, I just saw that I did not scroll until the top...
    Please see the complete process screen-shot

  6. Support Staff 6 Posted by Damien Elmes on 15 Nov, 2019 12:22 AM

    Damien Elmes's Avatar

    There should be a QtWebEngineProcess.exe in c:\program files\anki. If it is missing, perhaps your antivirus program has moved it somewhere by mistake?

  7. 7 Posted by Andreas on 15 Nov, 2019 11:33 AM

    Andreas's Avatar

    :-)

    You are a genius :-)

    Just for the case someone else has the same problem as me.
    I deactivated and deleted all malware and also windows firewall and windows defender. I installed anki again, nothing worked. There I found a report of a malware program as I searched for this QtWeb...exe file. I deleted it also.

    So after I installed and deactivated all this software and deleted this report, I deinstalled anki and downloaded it again and installed. Now it is working. I can not specify which step was the key issue but now its working.

    Thank you very much, I am appreciating your service and help.

  8. Support Staff 8 Posted by Damien Elmes on 15 Nov, 2019 08:48 PM

    Damien Elmes's Avatar

    Glad to hear you were able to resolve the issue :-)

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac