Unable to type in using ibus (Anki 2.1.15, Debian 10 Buster)

pollostrazon's Avatar

pollostrazon

21 Sep, 2019 05:00 PM

Good evening.

I have been using Anki on Debian for a long time and I use ibus to type in new cards in Russian (translit m17n) and Japanese (Mozc).
Suddenly, I could not type in new cards in Russian or Japanese when switching keyboards. The issue arose around yesterday.
It is very strange since other qt applications seem to work fine with ibus.
Did someone experienced something similar?
PS: If I did not provide useful information, I am sorry, this is my first time ever posting an issue!

Thanks to you all in advance.

  1. Support Staff 1 Posted by Damien Elmes on 23 Sep, 2019 12:52 AM

    Damien Elmes's Avatar

    If it's suddenly broken, it's probably something in your system that has changed. I'm afraid this is outside the scope of the support I can provide here - people on a Linux support forum might have some ideas for you.

  2. 2 Posted by pollostrazon on 23 Sep, 2019 09:39 AM

    pollostrazon's Avatar

    I'll defer to them, then.
    I decided to ask here first since I noticed it was the only qt application
    with this problem, as at first I thought it should have been some kind of
    compatibility problem between ibus and qt5.

    Thanks anyway.

  3. 3 Posted by pollostrazon on 23 Sep, 2019 09:41 AM

    pollostrazon's Avatar

    Removing this one which had the email template

  4. Support Staff 4 Posted by Damien Elmes on 23 Sep, 2019 11:20 PM

    Damien Elmes's Avatar

    Have you checked the env vars are defined, and tried running Anki from a terminal to see if it outputs anything?

     export XMODIFIERS=@im=ibus
     export QT_IM_MODULE=ibus
    
  5. 5 Posted by pollostrazon on 24 Sep, 2019 08:57 AM

    pollostrazon's Avatar

    Yes. I read through lots of posts for previous ibus versions and can assure that env vars are defined and correct.
    There is no strange output from terminal.

    I further investigate and another qt app (telegram) gives the same input problem with ibus. I then saw a similar issue on ibus Github page (https://github.com/ibus/ibus/issues/2137) and reported my problem, so I think the problem is with an ibus patch introduced in the last version.
    Therefore, I think that ibus is the problem and not Anki. Sorry for wasting your time and thanks for the support!

  6. Support Staff 6 Posted by Damien Elmes on 25 Sep, 2019 06:47 AM

    Damien Elmes's Avatar

    No problem, glad to hear you were able to get to the bottom of it.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac