Cannot input Japanese into Anki 2.1 on Linux

Jesse's Avatar

Jesse

04 Aug, 2018 04:35 AM

Running Linux Manjaro (Arch-based) x64. I have set up fcitx with mozc and I can switch between Japanese and Roman input on any other app. But for some reason Anki does not allow the IME to switch. Does anyone know what could be the potential issue?

I installed from the tarballs and tried both rc1, rc2, and then installed beta v40 from the Arch User Repository. Still the same result. Is there something I have to do to enable alternate input methods to work?

  1. Support Staff 1 Posted by Damien Elmes on 06 Aug, 2018 02:16 AM

    Damien Elmes's Avatar

    I'm afraid the bundled versions do not support fcitx at the moment, but they will work with ibus.

  2. 2 Posted by Jesse on 06 Aug, 2018 02:26 AM

    Jesse's Avatar

    Will the official 2.1 release be able to handle fcitx or other input methods? I am having a bit of an issue getting the proper keyboard layout to output Japanese with ibus since I use kana input instead of romaji. Let me know your plans big D! Thanks.

  3. Support Staff 3 Posted by Damien Elmes on 06 Aug, 2018 02:32 AM

    Damien Elmes's Avatar

    I'm not sure if it's practical to bundle the fcitx support at the moment - it's on the todo list to look into.

  4. 4 Posted by Jesse on 06 Aug, 2018 02:15 PM

    Jesse's Avatar

    Okay. Well whatever it takes. I'll help if I can. ibus-mozc will soon be deprecated. Once that happens, I won't have a reliable IME for ibus.

    See here regarding the owner's decision to deprecate it on GitHub. See the last comment for details.

    Edit: Until then, I guess I will use ibus-anthy, which I just tested to be working, even though it is scary old and has not been updated in like 7 years.

  5. Support Staff 5 Posted by Damien Elmes on 09 Aug, 2018 04:42 AM

    Damien Elmes's Avatar

    On an Ubuntu system that has a system Qt of 5.5, I was able to get it working using the following. It may work with other Qt versions as well. Does it work for you?

    • change to the Anki package folder you extracted
    • run: ln -s /usr/lib/x86_64-linux-gnu/qt5/plugins/platforminputcontexts/libfcitxplatforminputcontextplugin.so bin/qt5_plugins/platforminputcontexts/
      (adjust library location if your distro installs the file elsewhere)
    • run: bin/anki

    Please also try the attached version (pulled from Ubuntu 16.04) and let me know how you go.

  6. 6 Posted by Jesse on 09 Aug, 2018 05:00 PM

    Jesse's Avatar

    I will run you through my steps here. Please let me know if I properly linked the plugin.

    1. Set up input variables to use fcitx by default.
    2. Downloaded and extracted lib.zip file to ~/Downloads/libfcitxplatforminputcontextplugin.so
    3. Found the directory of Anki's install location with which anki:
      /usr/local/bin/anki
    4. found a platforminputcontexts folder in /usr/local/share/anki/bin/qt5_plugins/platforminputcontexts/ - see attached log for other platforminputcontexts locations
    5. Ran: ln -s ~/Downloads/libfcitxplatforminputcontextplugin.so /usr/local/share/anki/bin/qt5_plugins/platforminputcontexts/
    6. Restarted PC, opened Anki, and attempted input. Fcitx input switching is unresponsive within Anki, but operates normally on other applications.

    Also I attached a log of find / -name 'platforminputcontexts' in case you think I may have linked to the wrong one. You will see two fcitx plugins in there.

  7. Support Staff 7 Posted by Damien Elmes on 10 Aug, 2018 01:18 AM

    Damien Elmes's Avatar

    Thanks, that confirms that the Ubuntu one won't work. If you link the one in /usr/lib/qt/plugins/platforminputcontexts into /usr/local/share/anki/bin/qt5_plugins/platforminputcontexts/ and start Anki again, does it work? No need to restart your computer.

  8. 8 Posted by Jesse on 15 Aug, 2018 08:29 PM

    Jesse's Avatar

    Sorry this took a while, I deleted the current libfcitxplatforminputcontextplugin.so from /usr/local/share/anki/bin/qt5_plugins/platforminputcontexts/ and ran:

    sudo ln -s /usr/lib/qt/plugins/platforminputcontexts/libfcitxplatforminputcontextplugin.so /usr/local/share/anki/bin/qt5_plugins/platforminputcontexts/

    No luck after starting up Anki. Input is locked to Roman characters.

  9. Support Staff 9 Posted by Damien Elmes on 16 Aug, 2018 01:23 AM

    Damien Elmes's Avatar

    Thanks for giving it a go. I'm afraid that doesn't bode well for distributing the plugin with Anki. :-(

  10. 10 Posted by Jesse on 17 Aug, 2018 06:21 PM

    Jesse's Avatar

    No worries. I will just stick to iBus + Anthy. That should hold me over until a better IME comes along. Thanks for the attempt regardless.

  11. Support Staff 11 Posted by Damien Elmes on 28 Oct, 2018 01:00 AM

    Damien Elmes's Avatar

    Please let me know if the fcitx plugin I've bundled in the latest build works for you:

    https://anki.tenderapp.com/discussions/beta-testing/1303-linux-buil...

  12. 12 Posted by nemonein on 27 Nov, 2018 02:48 PM

    nemonein's Avatar

    Hi.
    Thank you for your great effort.

    I'm using fcitx(4.2.9.6-1) and fcitx-hangul(Korean) on KDE Neon(Kubuntu 18.04 based).
    I tried anki-2.1.6-beta2-linux-amd64-alt.tar.bz2 and anki-2.1.6-beta2-linux-amd64.tar.bz2, but each of them does not work.
    Beta1 does not work either.

    Using symbolic link of libfcitxplatforminputcontextplugin.so does not work.
    I hope you could find a solution for this matter.

    On the other hand, I tried Nimf(https://gitlab.com/nimf-i18n/nimf), and it's the same.
    However, the ln thing works.

    ln -s /usr/lib/x86_64-linux-gnu/qt5/plugins/platforminputcontexts/libqt5im-nimf.so bin/PyQt5/Qt/plugins/platforminputcontexts/
    
  13. Support Staff 13 Posted by Damien Elmes on 27 Nov, 2018 10:37 PM

    Damien Elmes's Avatar

    Thanks for letting me know

  14. 14 Posted by Jesse on 04 Dec, 2018 01:06 PM

    Jesse's Avatar

    I apologize that I forgot to get back to you on this. If you are still bundling the plugin in a current build, I can test it as well. Just let me know where to find a link to the latest build.

  15. Support Staff 15 Posted by Damien Elmes on 05 Dec, 2018 04:42 AM

    Damien Elmes's Avatar
  16. 16 Posted by Yorwba on 17 Dec, 2018 05:44 PM

    Yorwba's Avatar

    Is fcitx still supposed to be bundled? I tried the 2.1.7-standard and both beta versions currently available, and they only have the plugins for compose and ibus.

    Symlinking libfcitxplatforminputcontextplugin.so from the system Qt5 works for me. I suspect that the people who couldn't make it work with a symlink don't actually have fcitx with Qt5-support installed. Because symlinks are evaluated at access time, it's still possible to create the link, unfortunately without any warning that it's broken.

    On my Ubuntu 18.04 system, dpkg-query --search libfcitxplatforminputcontextplugin.so tells me that it's provided by the fcitx-frontend-qt5 package. Maybe those who can't make it work using the symlink don't have that package installed.

  17. Support Staff 17 Posted by Damien Elmes on 18 Dec, 2018 09:52 AM

    Damien Elmes's Avatar

    Sorry, it got lost when I updated to the release version of Qt 5.12. I've pushed out a new beta which should include it again, so symlinking should not be necessary:

    https://apps.ankiweb.net/downloads/beta/

  18. 18 Posted by nemonein on 18 Dec, 2018 12:34 PM

    nemonein's Avatar

    @Damien Elmes
    The latest beta(anki-2.1.8beta1-c740723e-linux-amd64.tar.bz2) works fine with fcitx.
    I tested with fcitx-hangul(Korean) on Kubuntu 18.04 and KDE Neon.

    Thank you for your effort.

  19. 19 Posted by bernhardt.d91 on 01 Dec, 2019 06:02 PM

    bernhardt.d91's Avatar

    Yeah... I just switched from 2.0 to 2.1 because Anki started to say "support for sync will be stopping for 2.0 next year" and now I'm hard handicapped for creating new cards, because I can't enter Japanese directly anymore. This is really a hard hit for me... Especially stopping supporting the old version when the new one is not as usable as the old was... :-(

    Version 2.1.15

  20. 20 Posted by bernhardt.d91 on 01 Dec, 2019 06:20 PM

    bernhardt.d91's Avatar

    UPDATE! (for anyone else, who finds this thread)

    On Arch you've to install community/fcitx-qt5 for Anki to work with!

Comments are closed, but you can start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac