anki crashes on Linux

sabayon11's Avatar

sabayon11

02 Sep, 2015 04:43 PM

Anki crashes repeatedly on Kubuntu 14.04.
I see there is a closed topic
https://anki.tenderapp.com/discussions/ankidesktop/7794-anki-continues-to-repeatedly-crash

Can you please have a look at attached report and check if this is the same cause?

A question for @princeofnam - have you found a solution?

  1. 1 Posted by chrono on 02 Sep, 2015 06:06 PM

    chrono's Avatar

    Looks like a problem with qtcurve theme. Maybe you can try newer version.

  2. 2 Posted by sabayon11 on 03 Sep, 2015 03:13 PM

    sabayon11's Avatar

    Newer version of Anki or newer version of qt?
    I have 2.0.32 version of Anki which is the newest.

    I've attached another two reports.

  3. 3 Posted by chrono on 03 Sep, 2015 10:24 PM

    chrono's Avatar

    Newer version of QtCurve theme (or you can try different KDE/Qt theme).

  4. 4 Posted by sabayon11 on 05 Sep, 2015 06:51 PM

    sabayon11's Avatar

    I changed qtcurve to oxygen but it keeps hanging.
    New report attached.

    Edit:
    Wait: Anki is still GTK2 app?

    I set oxygen-gtk for GTK2 apps and I will see if this changes anything.

  5. 5 Posted by chrono on 05 Sep, 2015 07:01 PM

    chrono's Avatar

    problem is still QtCurve:

    #2 0x00007fffe577d899 in ?? () from /usr/lib/kde4/plugins/styles/qtcurve.so

    (QtCurve is available for Gtk2 and KDE/Qt)

  6. 6 Posted by sabayon11 on 10 Sep, 2015 07:23 PM

    sabayon11's Avatar

    That's strange. Even when I set style to oxygen Anki keeps the style of qtcurve (which I recognize by the blue scrollbar).

    I can't update qtcurve - I would have to upgrade to new distribution release which I don't want to do because of only one program (at least until next LTS Kubuntu version will be available). Other programs work well with qtcurve.

    I may report a bug on Kubuntu buglist tracker but I don't know against what package to report. I am not sure if it is really qtcurve problem.

    It was mentioned that it might be dbus.

    https://anki.tenderapp.com/discussions/ankidesktop/14179-anki-quits...

    I wish Damien or Soren could comment on that and tell me what bug report should I report (against which package).

  7. 7 Posted by chrono on 11 Sep, 2015 12:33 PM

    chrono's Avatar

    Maybe you can uninstall QtCurve.

  8. 8 Posted by sabayon11 on 11 Sep, 2015 02:29 PM

    sabayon11's Avatar

    Of course I can but I prefer not to do that. It is better to find the source of the problem and fix it.
    Besides, the fun with Linux is that it can be customized to my liking and I really like qtcurve (one of the best style engines for KDE).

    Next crash report:
    bt Python Exception <class 'gdb.MemoryError'> Cannot access memory at address 0x7fffffffb0d8: #0 0x00007ffff3b14409 in ?? () from /usr/lib/python2.7/dist-packages/PyQt4/QtCore.so Cannot access memory at address 0x7fffffffb0d8

    This, as many other crashes, happened when I clicked on menu. Sometimes it happens when I click a keyboard shortcut to translate a word in a dictionary.

  9. Support Staff 9 Posted by Damien Elmes on 12 Sep, 2015 11:26 AM

    Damien Elmes's Avatar

    Uninstalling qtcurve would at least let you know whether the problem is caused by that theme or not. If the problem goes away when it is uninstalled, then you can debug it or chase it up with the theme author.

  10. 10 Posted by sabayon11 on 23 Sep, 2015 08:15 AM

    sabayon11's Avatar

    I noticed that the problem occurs only when in qtconfig I choose QtCurve as a GUI style. When I choose GTK+ as a GUI style there is no problem (while still having in system settings qtcurve as interface style and and qtcurve as GTK2 style).

    I reported a bug against qt4-x11
    https://bugs.launchpad.net/ubuntu/+source/qt4-x11/+bug/1495274

    I suspect that qt4-qtcurve is the source of the problem not qtcurve theme itself because other apps like Dolphin don't crash when I choose qtcurve in qtconfig. But I am not sure if I correctly identified the package that causes the problem.

    I wish I could set QtCurve as a GUI style in qtconfig because I want to use qtcurve in all applications, at least until next LTS.

    If anyone else has this bug please report on launchpad.

  11. Support Staff 11 Posted by Damien Elmes on 23 Sep, 2015 11:47 AM

    Damien Elmes's Avatar

    Glad to hear you were able to identify the cause of the problem.

  12. System closed this discussion on 22 Feb, 2016 11:47 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac