Image Occlusion Enhanced [Official thread]

Glutanimate's Avatar

Glutanimate

13 Oct, 2016 12:25 AM

This is the new official support thread for Image Occlusion Enhanced (old thread). From now on please direct all of your questions about the add-on here.

Thank you!

Showing page 3 out of 9. View the first page

  1. 61 Posted by Glutanimate on 26 Dec, 2016 02:25 PM

    Glutanimate's Avatar

    Yes, see here.

  2. 62 Posted by bILLyBob on 28 Dec, 2016 08:07 AM

    bILLyBob's Avatar

    Hey there.

    I am having a problem with opacity.

    Whenever I make a rectangle highlight something, I used to set the opacity to 50%

    But now, for some reason, no matter what % I set the opacity to, it always shows up as 100% when I'm actually using the cards.

    What'sup with that?

  3. 63 Posted by Glutanimate on 28 Dec, 2016 07:21 PM

    Glutanimate's Avatar

    Hi,

    support for opacity is very buggy in SVG-Edit (the image editor used by IO). In the past this would cause a lot of headaches, especially for OS X users. You can imagine how frustrating it can be when all your occlusion shapes that were meant to cover up your labels suddenly come out transparent. That's why the add-on now automatically strips all types of opacity attributes from the mask image. There's some more information on this here.

    If your workflow depends on having opacity available, you can edit the add-on's source code. Specifically you will have to replace this line in /image_occlusion_enhanced/ngen.py with:

    self.stripattr = []
    
  4. 64 Posted by bILLyBob on 29 Dec, 2016 02:34 PM

    bILLyBob's Avatar

    Hello Glutanimate

    I just tried that now, no cigar man.

    Opacity still defaults to 100% when viewing the cards.

    Doesn't work man, any other ideas?

    Ad thanks for the fast reply!

  5. 65 Posted by bILLyBob on 29 Dec, 2016 02:39 PM

    bILLyBob's Avatar

    Sorry, actually I fucked up.

    It's working!!!

    Thanks buddy!

  6. 66 Posted by amulelernen on 01 Jan, 2017 05:54 AM

    amulelernen's Avatar

    Hi Glutanimate,
    Thanks a lot. This add-on is awesome!
    And here's my problem: is there a way to generate only one pair of cards? If I cover the picture with multiple rectangles, Image Occlusion Enhanced will generate the same number of cards.But I think sometimes one pair of cards(with multiple rectangle covers) is enough, especially for "Hide all, reveal all".

  7. 67 Posted by Glutanimate on 01 Jan, 2017 03:32 PM

    Glutanimate's Avatar

    Hi amulelernen,

    you could try grouping your shapes together. Groups generate one card each. You can use this to freely control how many cards you will end up with.

  8. 68 Posted by Glutanimate on 14 Jan, 2017 04:52 PM

    Glutanimate's Avatar

    Hey guys,

    I've just released version 1.1.0 of Image Occlusion Enhanced on AnkiWeb. It comes with a few new features for the Masks Editor which I think should improve its usability. Here's the full changelog:

    • New: Grid-snapping for shapes can now be toggled via a button in the upper panel (hotkey: Shift+S)
    • New: Panning tool (hotkey: Q)
    • New: Control zoom levels with +/-
    • New: Reset zoom with 0
    • Fixed: Error when marking the Image field as sticky (thanks to vidale3 for the report)
    • Fixed: Ctrl+Shift+T now focuses the tag field again
    • Improved: Images now use the available canvas space slightly more efficiently
    • plus a number of smaller improvements and bug fixes

    As always: Enjoy the update and let me know what you think!

  9. 69 Posted by Glutanimate on 14 Feb, 2017 12:43 PM

    Glutanimate's Avatar

    Hey everyone,

    I've just pushed another update to AnkiWeb. Version 1.2.0 of Image Occlusion Enhanced mostly focuses on usability improvements, but it also comes with some under-the-hood changes that should make the add-on more efficient in terms of data use:

    • New: Hotkey for toggling masks on the answer side (G)
    • New: Preserve scrollbar position when revealing the answer
    • New: Reuse existing images when creating multiple occlusion sets from the same base image (thanks to @radroot for the suggestion)
    • New: Limit image display height in editor fields in order to improve navigating notes in the card browser
    • Changed: Updated default field order to move the question mask below the original image. Should make it easier to identify each respective card in the browser.
    • Fixed: Remove card margins on mobile devices
    • Fixed: Increased size of mask toggle button on mobile devices

    Please note that the changes to the field order and card templates only apply to new installations of the add-on. I've decided against enforcing these changes on existing installations as that would undo any customizations you might have applied to the note type. If you'd like to update your cards with these changes, please follow the instructions in the Wiki to reset your field order and card template to the (new) defaults.

    Looking forward to your feedback!

  10. 70 Posted by doan vo minh on 15 Feb, 2017 04:11 PM

    doan vo minh's Avatar

    HI, it's my first time using image occlusion. Everything seems to be fine except for the fact that there are EXTRA cards being generated!
    For example, I only have 3 occlusions on the image, but when i add, it says 11 cards are being generated. And the extra cards have no 'question' at all, i.e the 3 occlusions are there, but none of them become "red" to signal that they are the one being questioned.
    I will then have to go and delete all the extra cards, which is very inconvenient and time-consuming.
    What can i do?

  11. 71 Posted by Glutanimate on 15 Feb, 2017 06:52 PM

    Glutanimate's Avatar

    Hi,

    you're most likely drawing small shapes without noticing it (small as in 1 or 2 pixels wide). The rectangle tool is very sensitive, so you have to be careful not to do any extra clicks when drawing up your occlusion masks. There's more info on this in the Wiki: https://github.com/Glutanimate/image-occlusion-enhanced/wiki/Troubl... (see point 2)

  12. 72 Posted by doan vo minh on 15 Feb, 2017 09:36 PM

    doan vo minh's Avatar

    blockquote, div.yahoo_quoted { margin-left: 0 !important; border-left:1px #715FFA solid !important; padding-left:1ex !important; background-color:white !important; } Thank you very much Glutanimate.The Image Occlusion tool is extremely useful. Thanks again.

    Sent from Yahoo Mail for iPad

    On Wednesday, February 15, 2017, 7:52 PM, Glutanimate <[email blocked]> wrote:

     pre {width:92%;margin:10px 2%;padding:5px 2%;background:#efefef;border:1px solid #d6d6d6;}blockquote {margin-left:0;padding-left:1em;border-left:5px solid #ccc;}
    |

  13. 73 Posted by doan vo minh on 15 Feb, 2017 10:54 PM

    doan vo minh's Avatar

    blockquote, div.yahoo_quoted { margin-left: 0 !important; border-left:1px #715FFA solid !important; padding-left:1ex !important; background-color:white !important; } Dear Glutaminate,
    I realize that the problem comes from the fact that i use image from "snipping tool", WITHOUT pressing "New snip" everytime i capture a new image. When i try to press "New snip" everytime before I capture a new image, the extra card problem disappear. 
    Just telling u because u may add that to the list of potential problems. Thank you
    Sent from Yahoo Mail for iPad

    On Wednesday, February 15, 2017, 7:52 PM, Glutanimate <[email blocked]> wrote:

     pre {width:92%;margin:10px 2%;padding:5px 2%;background:#efefef;border:1px solid #d6d6d6;}blockquote {margin-left:0;padding-left:1em;border-left:5px solid #ccc;}
    |

  14. 74 Posted by doan vo minh on 15 Feb, 2017 11:02 PM

    doan vo minh's Avatar

    blockquote, div.yahoo_quoted { margin-left: 0 !important; border-left:1px #715FFA solid !important; padding-left:1ex !important; background-color:white !important; } Sorry i mean without pressing "copy" (Ctrl+C)

    Sent from Yahoo Mail for iPad

    On Wednesday, February 15, 2017, 11:50 PM, doan vo minh <[email blocked]> wrote:

    Dear Glutaminate,
    I realize that the problem comes from the fact that i use image from "snipping tool", WITHOUT pressing "New snip" everytime i capture a new image. When i try to press "New snip" everytime before I capture a new image, the extra card problem disappear. 
    Just telling u because u may add that to the list of potential problems. Thank you
    Sent from Yahoo Mail for iPad

    On Wednesday, February 15, 2017, 7:52 PM, Glutanimate <[email blocked]> wrote:

     pre {width:92%;margin:10px 2%;padding:5px 2%;background:#efefef;border:1px solid #d6d6d6;}blockquote {margin-left:0;padding-left:1em;border-left:5px solid #ccc;}
    |

  15. 75 Posted by Glutanimate on 16 Feb, 2017 05:03 AM

    Glutanimate's Avatar

    Glad you figured it out! Thanks for letting me know.

  16. 76 Posted by Ewa on 17 Feb, 2017 04:33 PM

    Ewa's Avatar

    Hey there,
    I'm having a problem with an error. It looks like this
    Traceback (most recent call last):
      File "C:\Users\piwew\OneDrive\Dokumenty\Anki\addons\image_occlusion_enhanced\dialogs.py", line 223, in addAA
        mw.ImgOccAdd.onAddNotesButton("aa", close)
      File "C:\Users\piwew\OneDrive\Dokumenty\Anki\addons\image_occlusion_enhanced\main.py", line 249, in onAddNotesButton
        mw.reset()
      File "aqt\main.py", line 434, in reset
      File "anki\hooks.py", line 26, in runHook
      File "C:\Users\piwew\OneDrive\Dokumenty\Anki\addons\ir\main.py", line 171, in restoreView
        cid = mw.reviewer.card.id
    AttributeError: 'NoneType' object has no attribute 'id'

    I'm not sure what to do.

    Thanks in advance,
    Ewa

  17. 77 Posted by Glutanimate on 17 Feb, 2017 04:44 PM

    Glutanimate's Avatar

    Hi Ewa,

    although this error message likely appeared when adding an IO note, it looks like it's actually caused by the Incremental Reading add-on (note the line addons\ir\main.py).

    You could try reporting it to @luoliyan here: https://anki.tenderapp.com/discussions/add-ons/9054-incremental-rea...

  18. 78 Posted by luoliyan on 18 Feb, 2017 12:14 AM

    luoliyan's Avatar

    Ewa, Glutanimate,

    Yes. It's usually safe to assume it's IR's fault, since it's hooked into almost everything. The only thing wrong with IO is that it made the mistake of being in bad company :-)

    Try the latest version (here), which has much more robust checks in place. If that doesn't work, let me know over in the other thread.

  19. 79 Posted by Glutanimate on 19 Feb, 2017 08:38 PM

    Glutanimate's Avatar

    @luoliyan: Thanks for chiming in. Glad to hear that the issue is resolved!

    Also: There's no need to sell your add-on short. I think you've done a stellar job at updating IR! Keep up the great work!

  20. 80 Posted by luoliyan on 20 Feb, 2017 04:10 AM

    luoliyan's Avatar

    Well thanks. It's surprising how much time a person will sink into maintaining a tool that's getting them through university. It's a difficult trade-off, though: Study, or improve the study tool? I'm sure you know the dilemma.

    You keep at it yourself. I think you'll find there's hardly a single person doing pre-med who isn't using Image Occlusion. A&P, histology, etc. would be living hell without IO, I imagine.

  21. 81 Posted by Rick on 07 Mar, 2017 04:26 AM

    Rick's Avatar

    First off, thank you for great product.

    I have a problem with viewing my cards. When opening up the IO cards in my deck or in preview mode, I cannot view the image. I attached screenshots; one card is supposed to show the Nervous System with 'occluded' images, but nothing is viewable.

    The 2nd screenshot shows the several fields, and a 'toggle masks' button in the middle that was absent from the previous screenshot. Nothing happens when I press the toggle mask button.

    I'm hoping there is an easier fix than trying to uninstall the whole program and reinstall it with each add-on. I thought it might be an add-on that's causing an issue, but I've deleted most of the questionable add-ons, I only have about 5 add-ons left, including IO Enhanced.

    Has anyone experienced this issue?

  22. 82 Posted by Glutanimate on 07 Mar, 2017 05:18 PM

    Glutanimate's Avatar

    @Rick:

    Two possible causes I can think of: Either an issue with your media collection or the card template.

    To rule out the first, please head into the edit screen from the reviewer ('E') and check whether your images appear there. If they don't, then the images are likely missing from your media collection, pointing towards a sync issue or another generalized problem with Anki. In that case please try asking in the general support section.

    If they images do appear in the edit screen, then something might be wrong with your card templates. In that case please follow the instructions in the Troubleshooting section to reset your card templates.

    Please let me know if you're still facing the issue after having gone through all of the above, so we can investigate further if need be.

  23. 83 Posted by Rick Siale on 07 Mar, 2017 08:41 PM

    Rick Siale's Avatar

    @Glutanimate:

    Thank you so much for the help! Solutions worked, but I will post my
    response in the forum to help others.

    Thanks!

  24. 84 Posted by Rick on 07 Mar, 2017 08:47 PM

    Rick's Avatar

    @Glutaminate:

    The 2nd solution you provided worked. I followed the instructions to edit the card templates. After that, everything works like a charm AND NO NEED TO UNINSTALL ANYTHING - WOOHOO!!!

    I love resolving tech issues without the usual, 'uninstall & reinstall' solution.

    FYI: When I checked the presence of the image in 'Preview', it appeared in the 'Image' field. Therefore, I proceeded with the 2nd solution.

    Great job! Thanks for the quick and EFFECTIVE response!

    PS: Sorry for the previous post, I didn't know responding via email would have posted a response.

  25. 85 Posted by Glutanimate on 08 Mar, 2017 12:05 AM

    Glutanimate's Avatar

    @Rick:

    Awesome. Glad to hear that all is back to normal. And thanks for taking the time to share your results here! That should definitely help future users if they happen to run into the same issue.

  26. 86 Posted by Renita on 11 Mar, 2017 06:18 AM

    Renita's Avatar

    I just downloaded the image occlusion enhanced version and an error has occured?
    After occluding parts of an image, I try to press add cards and this text appears:

    Traceback (most recent call last):
      File "C:\Users\whitt\AppData\Roaming\Anki2\addons\image_occlusion_enhanced\dialogs.py", line 221, in addAO
        mw.ImgOccAdd.onAddNotesButton("ao", close)
      File "C:\Users\whitt\AppData\Roaming\Anki2\addons\image_occlusion_enhanced\main.py", line 229, in onAddNotesButton
        gen = noteGenerator(self.ed, svg, self.image_path,
    AttributeError: 'ImgOccAdd' object has no attribute 'image_path'

    Can anyone help?

  27. 87 Posted by Glutanimate on 11 Mar, 2017 07:29 AM

    Glutanimate's Avatar

    Hi Renita,

    thanks for the report. Not quite sure what happened there. Is this error persistent or does it go away after restarting Anki? I'll check if I can find any issues in the code, but restarting Anki should help for now.

  28. 88 Posted by Renita Whittle on 11 Mar, 2017 07:38 AM

    Renita Whittle's Avatar

    Hi Glutanimate, thanks for your reply! Yes it actually did work after
    restarting my anki app! Thank you.

  29. 89 Posted by "Image Tool" Ex... on 03 Apr, 2017 10:53 AM

    &quot;Image Tool&quot; Explanation's Avatar

    Hi there Glutanimate, thanks so much for all your work on this wonderful add-on. A question - I've searched all of the tutorials and the wiki, but cannot find an explanation as to the usage of the "image tool". It seems to only add a flower image, and clicking on it allows me to see or change url "images/logo.png", but would you please be able to explain the usage of this tool? Can I add another smaller image over the original image? Thanks so much.

  30. 90 Posted by Follow up - Com... on 03 Apr, 2017 10:57 AM

    Follow up - Composite Image's Avatar

    One follow up question - is there a way to create a composite image? That is, use one original image, and paste another smaller image on top of it which I can click and drag to cover a certain part of the screen image? Hope my intention is clear. Thanks again.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac