Corrupt deck

james.scerbo's Avatar

james.scerbo

29 Apr, 2013 03:51 AM

I have a corrupt deck that I cannot seem to fix.

I have about 80 versions (I set my preferences up to 99).

I have gone as far back as 60 (I did not have any problems until 74) and still the deck appears to be corrupt.

I run the Check Database and it tells me the "Database has been rebuilt and optimized."

It appears to work fine.

The break tends to come from when I then add a new note from the ImageOcclusion 2.0 add-on. As soon as I try to study those cards I get the error that I will paste below.

(Note: as a test, I created another User on my desktop Anki application and in the default deck I created an image occlusion note without any problems.)

Also, I followed the Manual instructors with the sqlite3 method. That does not seem to have helped.

Please help. How do I get my deck back?

Or is it the collection that is corrupted?

I am not sophisticated with programming or things like sqlite3. I just know how to use the user interface of Anki and create and study cards.

Thank you.

Sincerely,
James

(PS: I purchased the iPhone app.)

  1. Support Staff 1 Posted by Damien Elmes on 30 Apr, 2013 03:30 PM

    Damien Elmes's Avatar

    It's probably a problem with your note type. Is your collection on AnkiWeb? What's your AnkiWeb ID and deck name?

  2. 2 Posted by james.scerbo on 01 May, 2013 03:20 PM

    james.scerbo's Avatar

    Dear Damien:

    Thank you for your reply; I really appreciate it. (I will be able to reply faster today than yesterday in which I had back to back meetings.)

    My AnkiWeb ID is my email james . scerbo at gmail . com
    The deck name is Unit3Munis
    It should have about 508 cards total. I created 2 notes with ImageOcclusion and that made maybe 8-12 cards of the 508.

    Fyi I also created a brand new AnkiWeb ID online (and Profile on the desktop version) with ID textplexus at gmail . com (same deck name). Into this ID I imported the single deck only. But I still have the issue.

    Another thing I tried is creating yet a third AnkiWeb ID and Profile on the desktop. The only thing I did in that ID and profile is ImageOcclusion cards. They work just fine. I did not import into this ID any of the decks I want and need (Unit3Munis). So then I thought I would try to export this working ImageOcclusion deck into both of the above ID's in which the Unit3Munis deck is my main deck. The import works fine but the errors pops up again as soon as I open the Browser or Study.

    I hope this information is helpful.

    Thank you.

    Sincerely,
    James

  3. Support Staff 3 Posted by Damien Elmes on 02 May, 2013 04:04 PM

    Damien Elmes's Avatar

    The three image occlusion notes in your collection only have 2 fields, when the note type has 6. If you delete the note type in tools>manage note types and then add it again, I suspect you won't have problems adding new notes in the future.

  4. 4 Posted by james.scerbo on 02 May, 2013 04:21 PM

    james.scerbo's Avatar

    I will try this right now and confirm.

    (I didn't set the note type, if I remember correctly. The add-on did it automatically.)

    Thank you.

  5. 5 Posted by james.scerbo on 02 May, 2013 04:38 PM

    james.scerbo's Avatar

    Dear Damien:

    I took a look at this and see 6 fields in the Note Type "Image Q/A - 2.1"

    I think I am looking at the right place: Tools / Manage Note Types / Image Q/A - 2.1 / Fields.

    The screen shot below shows what I found there.

    I did add a field actually called "Title.Mine" That shouldn't matter I think.

    Finally, your recommended adding the Note Type back in after deleting it. I don't know how to do that since it comes from the add-in installation (I think).

    Am I looking at the same place as you, because you mentioned you see 2 fields?

    Thank you.

    Sincerely,
    James

  6. 6 Posted by james.scerbo on 02 May, 2013 06:04 PM

    james.scerbo's Avatar

    Dear Damien:

    We have a partial resolution here!

    1. I deleted the Note Types and then re-made it manually. By manually, I mean I used another Profile with another AnkiID that had the Image Occlusion Note Type. I copied the 5 fields and then the 3 sections of the card. I put that into a text file and then went back to the Jamie Profile that associates with the AnkiWeb ID you reviewed. I then created a new Note Type with the same name, added 5 fields, and then pasted the code for the 3 card fields.

    2. The good news is that the error / bug no longer pops up and says I have a corrupt deck.

    3. The other good news is that I can create a new image occlusion card.

    4. However, it no longer creates multiple cards. The image occlusion editor operates smoothly and if I make 4 rectangles on the image to occlude those parts of the image the pop-up after I click "overlapping" tells me 1 note and 4 cards were created. .... But in fact when I go to learn the cards there is only 1 card: only 1 of the 4 occluded rectangles is generated.

    I am attaching the text file with the code for the 3 Card fields.

    Where do I go from there?

    Thank you.

    Sincerely,
    James Scerbo

  7. 7 Posted by Soren Bjornstad on 02 May, 2013 07:52 PM

    Soren Bjornstad's Avatar

    In case you have made the note type incorrectly or there is some special
    function in it, please try importing the note type rather than recreating
    it: create one image occlusion card in the new profile, export it as an
    apkg file, and then import it into your main profile.

  8. 8 Posted by james.scerbo on 03 May, 2013 01:47 AM

    james.scerbo's Avatar

    Dear Damien and Soren:

    I am back online. I was having a lot of trouble syncing today with Anki and I did a re-install of Anki and the ImageOcclusion add-on. I got numerous errors of 'handshake timeouts' during the day but now it is running fine..

    So, all new installs.

    I did what Soren recommended but actually accomplished it through the re-installs rather than an import from another working deck in another working Profile.

    That did the fix problem! Finally.

    I thank you both.

    Looking back I was trying to figure out where things went wrong so it can be avoided by other users in the future.

    This is my best guess:

    The add-on has the functionality of pulling an image from the clipboard and then clicking the icon within the "Add" note screen within the Anki program.

    When you click that icon, it brings up a "third-level" so that you can see on your menu bar at the bottom of your PC screen, the Anki program, the "Add" screen, and the ImageOcclusion screen. When you click the I.O. icon with the clipboard image, a new note pops up. Everything is automatically populated for you.

    To my eye this appeared to automatically change the Note Type for me: It was as if I didn't need to choose the Note Type from the get-go. So I was probably (based on Damien's analysis of having only 2 note fields) using the default Basic Note Type and then clicking the I.O. icon with an image on the clipboard. At that point, the I.O. "Add note" dialogue box popped up with all the right fields.

    ...to my eyes, the note type that pops up is exactly the one I need: the Image Occlusion one. It did not occur to me that the regular Anki "Add" dialogue box mattered b/c it was completely unused by me in the process.

    After I added the notes/cards in I.O. (by choosing the overlapping or non-overlapping option in I.O.), I just close the I.O. dialogue box and then the regular Anki dialogue "Add" box and go on with my work.

    It seems that someone unsophisticated with programming went with what I saw on the screen and did not consider the Note Type in the Anki "Add" dialogue box mattered when it came to this particular add-on since this add-on has its own "Add" dialogue box.

    I hope that is helpful. That is my best guess at how I personally messed this up. Clearly, I am in the minority. I don't know who your average user is, but I am not nearly as sophisticated as many of the people on your forums!

    Again, than you both very much.

    I am a huge fan of your software.

    Sincerely,
    James

  9. 9 Posted by Soren Bjornstad on 03 May, 2013 02:41 AM

    Soren Bjornstad's Avatar

    If you think that's the issue, please report it on the add-ons forum (
    https://groups.google.com/forum/#!forum/anki-addons) to the author of the
    add-on so that they can fix it.

  10. Soren Bjornstad closed this discussion on 03 May, 2013 02:41 AM.

  11. james.scerbo re-opened this discussion on 03 May, 2013 02:56 AM

  12. 10 Posted by james.scerbo on 03 May, 2013 02:56 AM

    james.scerbo's Avatar

    I will, Soren. Thank you. Sincerely, James

  13. Soren Bjornstad closed this discussion on 03 May, 2013 11:39 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac