Import eats quotation marks

Traveller's Avatar

Traveller

26 Apr, 2013 09:35 PM

I imported data, exported it again and then I compared the imported and the exported text files, using a file compare program.
This way I found out, that after the import in some fields the quotation marks were missing.
Here is the imported and the exported text of a faulty field of a data set :

Imported: "Es hat" ist invariabel {unveränderbar}.
Exported: Es hat ist invariabel {unveränderbar}.

It seems, that only the first pair of quotation marks is removed:

Imported: "-teur" wird (zu) "-trice" für fast alle Berufe.
Exported: -teur wird (zu) "-trice" für fast alle Berufe.
  1. 1 Posted by Soren Bjornstad on 27 Apr, 2013 04:53 PM

    Soren Bjornstad's Avatar

    Added to the todo to look at, thanks.

  2. Soren Bjornstad closed this discussion on 27 Apr, 2013 04:53 PM.

  3. Damien Elmes re-opened this discussion on 16 May, 2013 05:58 AM

  4. Support Staff 2 Posted by Damien Elmes on 16 May, 2013 05:58 AM

    Damien Elmes's Avatar

    Unfortunately this seems to be a limitation of the csv parsing library Anki uses - I can't see any way to handle this without extra options to control quoting characters, which will probably confuse the bulk of users.

  5. 3 Posted by Soren Bjornstad on 16 May, 2013 11:27 AM

    Soren Bjornstad's Avatar

    Could there be an add-on that changes it for users who run into the problem
    and need to fix it?

  6. Support Staff 4 Posted by Damien Elmes on 16 May, 2013 12:11 PM

    Damien Elmes's Avatar

    Yes, if someone wrote an add-on they could tell the parser to ignore quotes.

  7. 5 Posted by mnhende2 on 16 May, 2013 12:26 PM

    mnhende2's Avatar

    I would be great if the export didn't eat the quotes. I think it does
    it with a single quote also '

    I'm going to post this on the addons on page and see if anyone would be
    willing to write an add on for it.

    I loose quote marks on exports all the time.

  8. 6 Posted by Soren Bjornstad on 16 May, 2013 08:34 PM

    Soren Bjornstad's Avatar

    Please reopen if anything else is needed.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac