Audio not working

Daniel's Avatar

Daniel

21 Apr, 2013 07:59 AM

On the front card, The audo recording worked fine. When adding an audio recording to all the acks of the cards, none of them played when viewing the cards. The back recording played back just fine during the recording. I've notice this happen a few times with pictures as well.

  1. 1 Posted by Daniel on 21 Apr, 2013 08:14 AM

    Daniel's Avatar

    another screenshot of the problem. Why does it let the audio play on the front of the card and not on the back? It renders this useless for language learning.

  2. Support Staff 2 Posted by Damien Elmes on 22 Apr, 2013 10:37 AM

    Damien Elmes's Avatar

    If you want the audio to play when the back is shown, you need to put the field with the audio on the back of your card.

  3. 3 Posted by Daniel on 22 Apr, 2013 11:51 AM

    Daniel's Avatar

    So it is impossible to have the audio on the front and back of every card? Must I remove the audio field from the front of every card to get the audio field on the back to play?

  4. 4 Posted by Daniel on 22 Apr, 2013 08:27 PM

    Daniel's Avatar

    I tried deleting all the audio fields from the front of all the cards in the deck. Problem not solved. This makes it a very very useless tool for studying language if I can't type it in the language I'm trying to learn, and hear it from the native speaker's recording after I type it. It's a shame, because I planned on making loads of flashcards, even pertaining too many advanced textbooks, with pictures and audio of the native speaker, and sharing it with the Swedish learning community, which is super small in comparison to other languages, like Spanish, English, or even Japanese. I wish I could solve this problem, because if this were solved, this would be quite the ideal program for flash card making, and sharing the cards with others.

  5. 5 Posted by Soren Bjornstad on 22 Apr, 2013 10:30 PM

    Soren Bjornstad's Avatar

    Have you tried making a new field in the Fields dialog, placing the audio
    in it, and then adding that field to the back of your card on the template
    in the Cards window?

    (something like {{Back}}<br>{{AudioField}})?

  6. 6 Posted by Daniel on 23 Apr, 2013 08:21 AM

    Daniel's Avatar

    Thanks, Bjornstad! This has solved my dilemma! Excellent! Very very good, thank you. Now, this program has great potential!

  7. 7 Posted by Daniel on 23 Apr, 2013 08:29 AM

    Daniel's Avatar

    I'm not sure if it was that that fixed the problem. It may be because I added another field, or because of this {{Back}}
    {{AudioField}} on the back of the card. I noted at the top in the tabs I had card 1 and card 2, and I deleted card two after the problem was solved. On all of the rest of the cards, the only thing that remained the same, is that I added another field on the back of the card, but {{Back}}
    {{AudioField}} wasn't added to every card.

  8. 8 Posted by Soren Bjornstad on 23 Apr, 2013 11:24 AM

    Soren Bjornstad's Avatar

    If the AudioField didn't get added to every card, then some of the cards
    have a different note type. If that's a problem, you can change them with
    Edit → Change Note Type in the browser.

  9. 9 Posted by Soren Bjornstad on 17 May, 2013 06:00 PM

    Soren Bjornstad's Avatar

    If you are still having problems, feel free to reopen this.

  10. Soren Bjornstad closed this discussion on 17 May, 2013 06:00 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac