No sound in the Linux version

Jenny's Avatar

Jenny

20 Apr, 2013 01:56 PM

Hello,

I have my Anki deck set up in both Windows 7 and Linux Mint that was originally created on my Mac. The sound files work perfectly under Windows, but I can't get it under Linux. Would anyone have suggestions of what I'm missing that I need to install or otherwise do to get the sound?

I have checked the sound control panel and everything seems to be working. Youtube works fine. I'm using LinuxMint 14 w/Cinnamon.

Thanks.

  1. 1 Posted by Soren Bjornstad on 20 Apr, 2013 02:25 PM

    Soren Bjornstad's Avatar

    mplayer should probably be installed, but it might be worth checking to
    make sure it is. If it is, please try playing a few of your Anki media
    files from the command-line, and if that doesn't work, go from there.

  2. 2 Posted by Jenny on 20 Apr, 2013 03:09 PM

    Jenny's Avatar

    using the play command in the terminal did bring up mplayer and it played normally.

    Anything else I need to install?

    Thanks for your help.

  3. 3 Posted by Soren Bjornstad on 20 Apr, 2013 06:41 PM

    Soren Bjornstad's Avatar

    Please try looking at whatever mixer you have and making sure Anki's sound is turned up.

    Also, you can take a look at the dependencies here to make sure you have everything installed.

  4. 4 Posted by Jenny Adams on 20 Apr, 2013 06:44 PM

    Jenny Adams's Avatar

    Thanks. I'll take a look and see if I have everything installed.

  5. Support Staff 5 Posted by Damien Elmes on 21 Apr, 2013 05:32 AM

    Damien Elmes's Avatar

    Anki expects a program called 'mplayer' to exist. You said 'play command'; please try typing mplayer in the terminal and ensure it runs.

  6. 6 Posted by Jenny Adams on 21 Apr, 2013 01:49 PM

    Jenny Adams's Avatar

    I checked and I have all the files. It's finally working as I've had to
    fiddle with every possible combination of hardware and output settings.

    Thanks to all that helped.

  7. 7 Posted by Soren Bjornstad on 21 Apr, 2013 06:48 PM

    Soren Bjornstad's Avatar

    Glad you got it working.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac