unable to export deck as a package

didikoch's Avatar

didikoch

18 Apr, 2013 04:05 PM

when i attempt to export my deck i receive the following error message:

An error occurred. It may have been caused by a harmless bug,
or your deck may have a problem.
To confirm it's not a problem with your deck, please run Tools > Maintenance > Check Database.
If that doesn't fix the problem, please copy the following
into a bug report:
Traceback (most recent call last):
File "C:\cygwin\home\dae\win\build\pyi.win32\anki\outPYZ1.pyz/aqt.exporting", line 83, in accept File "C:\cygwin\home\dae\win\build\pyi.win32\anki\outPYZ1.pyz/anki.exporting", line 225, in exportInto File "C:\cygwin\home\dae\win\build\pyi.win32\anki\outPYZ1.pyz/anki.exporting", line 268, in exportVerbatim File "C:\cygwin\home\dae\win\build\pyi.win32\anki\outPYZ1.pyz/zipfile", line 1080, in write IOError: [Errno 22] Invalid argument

I have already run the "check database" tool 3 times and it doesn't help. Can someone please advise me what I can do in order to successfully export the file?

Thank you very much.

  1. Support Staff 1 Posted by Damien Elmes on 19 Apr, 2013 01:17 AM

    Damien Elmes's Avatar

    Please ensure you're trying to export it to a valid filename in a folder you can write to.

  2. 2 Posted by didikoch on 19 Apr, 2013 03:19 AM

    didikoch's Avatar

    The filename is just "collection" and I'm trying to export to my computer's desktop. I have done this many times before without any problems. This is the first time that I have seen this error message.

  3. 3 Posted by Soren Bjornstad on 19 Apr, 2013 11:25 AM

    Soren Bjornstad's Avatar

    Have you tried rebooting to make sure there's not a temporary filesystem
    error? If not, please do.

  4. 4 Posted by Soren Bjornstad on 29 Apr, 2013 01:10 AM

    Soren Bjornstad's Avatar

    If you have not solved the problem, please report back.

  5. Soren Bjornstad closed this discussion on 29 Apr, 2013 01:10 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac