New Version Not Opening on Windows 7

CL's Avatar

CL

16 Apr, 2013 03:50 AM

Hey,

I've tried several times to download and start the new version on my Windows 7, but it simply doesn't open. There is no message that suggests why. So far only the old version has been working for me, but, as you know, this doesn't sync with AnkiWeb or mobile devices. Is there a bug in the program or is there something I can do?

  1. Support Staff 1 Posted by Damien Elmes on 16 Apr, 2013 03:58 AM

    Damien Elmes's Avatar

    A few other people have reported this problem, but I haven't yet been able
    to track down why it's happening.

    Does the beta version suffer from the same problem?

    https://anki.tenderapp.com/discussions/beta-testing/2-test-build-with-updated-toolkit-windows

    Do you have any antivirus/firewall software installed, and if so does
    disabling it help?

    If problems persist, does installing any of these packages help? (please
    test after each one)

    http://www.microsoft.com/en-us/download/details.aspx?id=5582
    http://www.microsoft.com/en-us/download/details.aspx?id=5555
    http://download.cnet.com/Microsoft-DirectX-Drivers-Redistributable/3000-2121_4-10305889.html

  2. 2 Posted by Yuriy on 21 Apr, 2013 06:32 PM

    Yuriy's Avatar

    I've the same problem...

  3. Support Staff 3 Posted by Damien Elmes on 22 Apr, 2013 09:52 AM

    Damien Elmes's Avatar

    Have you tried the things I mentioned in my previous reply?

  4. 4 Posted by Yuriy on 22 Apr, 2013 07:04 PM

    Yuriy's Avatar

    I've tried the things but nothing helped. Even previous versions don't open. I fully disabled my antivirus (avast), but it didn't help too.

  5. Support Staff 5 Posted by Damien Elmes on 24 Apr, 2013 03:08 AM

    Damien Elmes's Avatar

    I'm swamped at the moment I'm afraid, but if you stay subscribed to this message I'll post back when I've had a chance to build a debug version that may reveal what the problem is.

  6. Support Staff 6 Posted by Damien Elmes on 09 May, 2013 07:25 AM

    Damien Elmes's Avatar

    Sorry for the delay. Please try with the latest build:

    https://anki.tenderapp.com/discussions/beta-testing/9-test-build-wi...

    Instead of running it directly, please use Start>Run and type cmd.exe. When a console window appears, please type

    cd \program files\anki
    anki

    If that doesn't work, please try

    cd \program files (x86)\anki
    anki

    Presumably Anki will fail to open like before. But it should give you some lines of debugging info; please paste what you see here.

  7. 7 Posted by Юрий Жартанов on 09 May, 2013 03:29 PM

    Юрий Жартанов's Avatar

    Hi, Damien.

    There are results:

    C:\Program Files\Anki>anki
    Found embedded PKG: C:\Program Files\Anki\anki.exe
    Extracting binaries
    manifestpath: C:\Program Files\Anki\anki.exe.manifest
    Activation context created
    Activation context activated
    C:\Program Files\Anki\python27.dll
    Manipulating evironment
    PYTHONPATH=C:/Program Files/Anki
    importing modules from CArchive
    extracted iu
    extracted struct
    extracted archive
    Installing import hooks
    outPYZ1.pyz
    Running scripts
    Traceback (most recent call last):
    File "<string>", line 6, in <module>
    File "C:\cygwin\home\dae\win\build\pyi.win32\anki\outPYZ1.pyz/aqt", line 225,
    in run
    File "C:\cygwin\home\dae\win\build\pyi.win32\anki\outPYZ1.pyz/aqt.profiles", l
    ine 63, in __init__
    File "C:\cygwin\home\dae\win\build\pyi.win32\anki\outPYZ1.pyz/aqt.profiles", l
    ine 186, in _defaultBase
    File "C:\cygwin\home\dae\win\build\pyi.win32\anki\outPYZ1.pyz/ntpath", line 96
    , in join
    TypeError: object of type 'NoneType' has no len()
    RC: -1 from runanki
    OK.

    Best regards,

    Yuriy

    Четверг, 9 мая 2013, 3:25 -04:00 от "Damien Elmes" <[email blocked]> :

  8. Support Staff 8 Posted by Damien Elmes on 10 May, 2013 03:33 AM

    Damien Elmes's Avatar

    Ok, this seems to indicate your computer is not configured correctly. The location of the Documents folder should be stored in the following key in the registry:

    UserScope:/Microsoft/Windows/CurrentVersion/Explorer/Shell Folders/Personal

    Anki seems to be getting no value from that key, and so it's unable to create the Documents/Anki folder. If you run the 'fix it' program on http://support.microsoft.com/kb/886549 does it fix the problem?

  9. Support Staff 9 Posted by Damien Elmes on 10 May, 2013 03:34 AM

    Damien Elmes's Avatar

    See also: http://answers.microsoft.com/en-us/windows/forum/windows_vista-wind...

    Is it possible you dragged & dropped your Documents folder elsewhere in the past?

  10. 10 Posted by Yuriy on 11 May, 2013 10:26 AM

    Yuriy's Avatar

    I ran the 'fix it' program, but it didn't help. I checked my register paramentrs, but there is nothing wrong I guess. See attached skrinshot.

  11. Support Staff 11 Posted by Damien Elmes on 11 May, 2013 11:00 AM

    Damien Elmes's Avatar

    How about "Shell Folders" rather than "User Shell Folders"? In cmd.exe, if
    you type 'echo %USERPROFILE%', what do you see?

  12. 12 Posted by Yuriy on 11 May, 2013 11:44 AM

    Yuriy's Avatar

    I created new Expandable String Value (%USERPROFILE%\Documents), then it seemed to be ok. Thanks.

  13. Support Staff 13 Posted by Damien Elmes on 12 May, 2013 09:18 AM

    Damien Elmes's Avatar

    Thanks for all the info. Anki should handle this automatically in the next release.

  14. Damien Elmes closed this discussion on 05 Jun, 2013 10:42 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac