Anki close unexpectedly

nomnex's Avatar

nomnex

06 Apr, 2013 06:32 AM

Anki is open (deck window). I open the browser. I bring the Anki deck window in the foreground. The browser window is in the background. I click any of the deck wheel > options. When I click OK, Anki close unexpectedly (i.e. the application, not the options window).

Fedora Linux, Anki 2.08.

  1. 1 Posted by Soren Bjornstad on 06 Apr, 2013 07:17 PM

    Soren Bjornstad's Avatar

    If you run Anki in the terminal, do you get any traceback information?

  2. 2 Posted by nomnex on 06 Apr, 2013 09:28 PM

    nomnex's Avatar

    Nope,

    [nomnex@nh28d anki]$ python runanki
    /home/nomnex/Anki/addons/code_highlight_addon/pygments/plugin.py:39: UserWarning: Module anki was already imported from /home/nomnex/local/anki/anki/__init__.pyc, but /usr/lib/python2.7/site-packages is being added to sys.path
      import pkg_resources
    Your pysqlite2 is too old. Anki will appear frozen during long operations.
    

    And I can't reproduce the issue after a reboot this morning. That's good news!

    Thanks Soren.

  3. nomnex closed this discussion on 06 Apr, 2013 09:34 PM.

  4. nomnex re-opened this discussion on 06 Apr, 2013 09:44 PM

  5. 3 Posted by nomnex on 06 Apr, 2013 09:58 PM

    nomnex's Avatar

    Crap, I spoke too soon.

    I get a 'Segmentation fault' message when a crash occurs.

    I can reproduce the crash as follow:

    1. Launch Anki
    2. Open the browser
      2.1. Click on "Review" (right pane)
    3. Bring the Anki window in the foreground
      3.1. Click on the wheel of a deck > select Options
      3.2. Change a setting (e.g. Review tab, from 100 cards to 5 cards)
      3.3. Click on OK --> Anki terminates.
  6. Support Staff 4 Posted by Damien Elmes on 07 Apr, 2013 10:41 PM

    Damien Elmes's Avatar

    Your Qt libraries are probably buggy. Please run

    gdb --args python /usr/bin/anki

    then type 'run', and when it crashes, 'bt', and paste the resulting output here.

  7. 5 Posted by nomnex on 07 Apr, 2013 11:50 PM

    nomnex's Avatar

    Good morning. To run Anki2, I have copied the anki 2.0.8 tarball to /usr/share/ and created a softlink to /usr/share/anki/runanki. I am not sure if it is the correct way to run it? I still have anki 1 installed in the default location /usr/bin/anki.

    [mt@nh28d ~]$ gdb --args python /usr/share/anki/ GNU gdb (GDB) Fedora (7.3.1-48.fc15)
    Copyright (C) 2011 Free Software Foundation, Inc.
    License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law. Type "show copying"
    and "show warranty" for details.
    This GDB was configured as "i686-redhat-linux-gnu".
    For bug reporting instructions, please see:
    http://www.gnu.org/software/gdb/bugs/...
    Reading symbols from /usr/bin/python...(no debugging symbols found)...done.
    Missing separate debuginfos, use: debuginfo-install python-2.7.1-7.fc15.i686
    (gdb) run Starting program: /usr/bin/python /usr/share/anki/
    [Thread debugging using libthread_db enabled] /usr/bin/python: can't find '__main__' module in '/usr/share/anki/' Inferior 1 (process 2600) exited with code 01

  8. Support Staff 6 Posted by Damien Elmes on 07 Apr, 2013 11:53 PM

    Damien Elmes's Avatar

    You must pass the Anki 2 binary path to gdb

  9. 7 Posted by nomnex on 08 Apr, 2013 12:36 AM

    nomnex's Avatar

    I can debug the file now, but I can't reproduce the unexpected close on demand. I keep an eye on it today. If it happens again, I will pass 'bt' without argument, as below.

    Starting program: /usr/bin/python
    [Thread debugging using libthread_db enabled] Python 2.7.1 (r271:86832, Apr 12 2011, 16:16:18)
    [GCC 4.6.0 20110331 (Red Hat 4.6.0-2)] on linux2 Type "help", "copyright", "credits" or "license" for more information.

    bt Traceback (most recent call last):
    File "", line 1, in NameError: name 'bt' is not defined

  10. Support Staff 8 Posted by Damien Elmes on 08 Apr, 2013 01:19 AM

    Damien Elmes's Avatar

    That's not correct; it looks like you did not pass the path to the Anki binary.

  11. 9 Posted by nomnex on 08 Apr, 2013 02:05 AM

    nomnex's Avatar

    Anki is in '/usr/share/anki'. I passed the command 'gdb /usr/share/anki --args python', which is wrong.

    I don't know which one of the python scripts is the Anki binary? is it 'usr/share/anki/aqt/main.py'?

  12. 10 Posted by Soren Bjornstad on 08 Apr, 2013 02:53 AM

    Soren Bjornstad's Avatar

    It's "runanki" in the top-level directory.

  13. 11 Posted by nomnex on 08 Apr, 2013 04:06 AM

    nomnex's Avatar

    Thank you Soren. I have seen it in the Makefile 'mv runanki ${DESTDIR}${PREFIX}/local/bin/anki;\' but did not know the difference between compiled Languages vs. scripting Languages till now, and I was looking for a complied binary file, as for C applications...

    http://eimg.wordpress.com/2007/12/31/compiled-languages-vs-scriptin...

  14. 12 Posted by nomnex on 13 Apr, 2013 03:54 AM

    nomnex's Avatar

    It's been five days and I can't reproduce the problem. I will close the thread by next week.

  15. 13 Posted by Soren Bjornstad on 20 Apr, 2013 02:41 PM

    Soren Bjornstad's Avatar

    (Closing for you as it's been a week; please reopen if the issue comes back.)

  16. Soren Bjornstad closed this discussion on 20 Apr, 2013 02:41 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac