Ubuntu 13.04 won't work with Anki 2

Will's Avatar

Will

04 Apr, 2013 02:19 AM

I just upgraded to Ubuntu 13.04 and Anki 2 will not open for some reason.

  1. 1 Posted by Soren Bjornstad on 04 Apr, 2013 02:28 AM

    Soren Bjornstad's Avatar

    If you run 'anki' in a terminal, do you get an error message?

  2. 2 Posted by will on 05 Apr, 2013 04:31 AM

    will's Avatar

    Yes here it is
    QGtkStyle was unable to detect the current GTK+ theme.
    Traceback (most recent call last):
    File "/usr/bin/anki", line 6, in aqt.run() File "/usr/share/anki/aqt/__init__.py", line 213, in run pm = ProfileManager(opts.base, opts.profile) File "/usr/share/anki/aqt/profiles.py", line 64, in init self.firstRun = self._loadMeta() File "/usr/share/anki/aqt/profiles.py", line 207, in loadMeta "select data from profiles where name = 'global'")) TypeError: must be string, not None

  3. Support Staff 3 Posted by Damien Elmes on 07 Apr, 2013 09:53 PM

    Damien Elmes's Avatar

    Your config has become corrupted. You can fix this by deleting ~/Anki/prefs.db and starting Anki again. The next release should handle this automatically.

  4. 4 Posted by William Hunt on 08 Apr, 2013 09:43 PM

    William Hunt's Avatar

    I tried to do that, but Anki still refuses to open. I deleted the files
    through the trash and through the terminal. Neither worked.

  5. 5 Posted by Soren Bjornstad on 08 Apr, 2013 10:35 PM

    Soren Bjornstad's Avatar

    Does Anki re-create that file? Are you still getting the same error when
    you run through the terminal?

  6. 6 Posted by Soren Bjornstad on 20 Apr, 2013 02:37 PM

    Soren Bjornstad's Avatar

    If you have not solved the problem, feel free to reopen this ticket.

  7. Soren Bjornstad closed this discussion on 20 Apr, 2013 02:37 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac