Can't open without hardware acceleration

tkyleh's Avatar

tkyleh

05 Jun, 2020 09:01 PM

I keep getting the OpenGL dialogue box when I try to disable the hardware acceleration. I'm having a problem with cards not displaying the answers when I press the reveal button. The few times I have been able to disable hardware acceleration, the answer problem is fixed and anki displays much more responsively. The generic solution of "anki's known issues for hardware acceleration" does nothing. I'm on windows. In Cmd prompt as administrator, when I enter the command, nothing happens.

  1. 1 Posted by addons_zz on 05 Jun, 2020 11:35 PM

    addons_zz's Avatar
    1. What command did you enter?
    2. What do you expect to happen and it is not happening?
  2. 2 Posted by kelciour on 06 Jun, 2020 05:56 AM

    kelciour's Avatar

    Maybe try to update your video card drivers, Intel HD Graphics or something, if it can be done. The hardware acceleration might work a bit better after this.

  3. 3 Posted by tkyleh on 06 Jun, 2020 02:11 PM

    tkyleh's Avatar

    Thanks for your prompt replies:
    1. echo auto > %APPDATA%\Anki2\gldriver
    -I adjusted then replacing 'auto' with 'angle' and 'software' to no avail.
    2. I expected to either be able to adjust hardware acceleration or for the reveal bug to go away. I also didn't receive any indication that windows had executed my command (though I don't know if I am supposed to, the dialogue box just moved down waiting for the next command).

    I thought it might be an issue with my driver so I updated it, thinking that might fix it. When the issue persisted I investigated the driver update and saw an error with 'kronos' and I know that is affiliated with the OpenGL suite. I don't know if I should revert my driver and then reattempt the update to fix the kronos error.

  4. 4 Posted by addons_zz on 06 Jun, 2020 10:01 PM

    addons_zz's Avatar

    I also didn't receive any indication that windows had executed my command (though I don't know if I am supposed to, the dialogue box just moved down waiting for the next command).

    That means everything worked fine. When the command echo etc... does not work, it will show you an error. But when it works, it just shows nothing and the dialogue box just moves down waiting for the next command.

    What you have to do is to run each echo etc command with auto, etc. After each time you do it, you open Anki and test if things are working correctly or not.

    I don't know if I should revert my driver and then reattempt the update to fix the kronos error.

    If none of the options using auto, angle, etc with echo thing works for you, you can try updating your card driver to the latest version. If it still not working, you can try installing some older version of the drivers.

  5. 5 Posted by tkyleh on 06 Jun, 2020 10:39 PM

    tkyleh's Avatar

    "What you have to do is to run each echo etc command with auto, etc. After each time you do it, you open Anki and test if things are working correctly or not."

    So with Anki closed I need to enter the cmd, then begin my reviews in Anki to see if the bug continues. If I find a setting that fixes the issue, will I need to enter the command each time I run Anki or will the setting stick after I enter it the first time?

  6. 6 Posted by addons_zz on 07 Jun, 2020 01:57 AM

    addons_zz's Avatar

    So with Anki closed I need to enter the cmd, then begin my reviews in Anki to see if the bug continues.

    Yes.

    If I find a setting that fixes the issue, will I need to enter the command each time I run Anki or will the setting stick after I enter it the first time?

    The setting will stick after you enter it.

    When you do echo auto > %APPDATA%\Anki2\gldriver you are just creating a file on the location %APPDATA%\Anki2\gldriver. If you are curious, you can go to %APPDATA%\Anki2 and see there will be a file named gldriver with the contents auto.

Comments are closed, but you can start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac