Anki displayed error in opening collection file

Joe's Avatar

Joe

17 May, 2020 03:38 AM

Good day all, I just found out that there was a problem with my Anki application in my PC. This happened right after I tried to open a newly downloaded Anki version (v2.1.26 at 64bit). Immediately after opening the app I was prompted with the message: "Anki was unable to open collection file..." (elaborated info in attach).

Though I was able to access the app profile page, my profile is unable to restore a backup collection that was saved before the error was first seen. An error message popped up when I tried to restore the file in my backup collection: "Unable to move existing file to trash - please restart your computer".

Measures I had tried include:

1. Reinstalling Anki app to all available versions 2.1.22 and 2.1.15
2. Holding shift during starting of Anki app to disable add-ons loadings
3. Restarting my laptop and ensuring it is in the latest version of Windows.

Would deeply appreciate any input that can help resolve this issue as quickly as possible - have a major quiz coming up tomorrow and I require Anki extensively :(

  1. 1 Posted by addons_zz on 18 May, 2020 02:17 AM

    addons_zz's Avatar

    I recommend deleting all addons until you resolve this issue. (just move them to another directory https://docs.ankiweb.net/#/files?id=file-locations)

    Install the latest version of Anki from https://apps.ankiweb.net/ and read the warning at: https://changes.ankiweb.net/#/ before installing older versions of Anki

    After using the latest version, if you wish to open your collection with an earlier Anki release, please go to the File>Switch Profile menu item, and click on “Downgrade & Quit”. If you skip this step, you may get an error message when opening your collection in an older Anki version, and you will need to return to this version, downgrade, then try again.

  2. 2 Posted by Joe on 18 May, 2020 02:46 AM

    Joe's Avatar

    Hi, thank you for the reply. Based on your recommendation, my Anki got to work again.
    Deeply appreciate the prompt reply.

    A tip for those who have such persistent problem (even after moving the add-ons), you may try to create another new profile and import all your old profile's content to the newly created one. It worked for me at least before the solution was recommended.

Comments are closed, but you can start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac