Anki 2.1.24: Recording not working on macos

Max Ibel's Avatar

Max Ibel

29 Apr, 2020 06:28 PM

If I edit a card and then record, anki faithfully opens a recording window and lets me record something. However, the recording seems to be entirely empty.

Interestingly enough, Anki did not ask for microphone permissions (MacOs 10.15.3), nor can I enable them in the global preferences - anki just doesn't show up there.

I suspect that the current build (2.1.24) does not register the need for microphone from the OS and hence can't record.

Is there a workaround like editing some plist file ?

  1. Support Staff 1 Posted by Damien Elmes on 30 Apr, 2020 04:32 AM

    Damien Elmes's Avatar

    I've made a change which should correct this - please let me know how you go with 2.1.25:

  2. 2 Posted by Max Ibel on 30 Apr, 2020 05:06 PM

    Max Ibel's Avatar

    Excellent. This version asks for microphone permissions. After granting
    them and restarting anki, I could record properly.

    I seem to have trouble immediately hearing a new recoding after editing a
    card. Maybe Anki caches the contents of the media collection and does not
    recompute it after editing a card within Anki ? Anyway, 2.1.25 seems to
    solve my biggest problems, thanks a lot and be safe


  3. Support Staff 3 Posted by Damien Elmes on 01 May, 2020 04:26 AM

    Damien Elmes's Avatar

    Thanks for testing, Max. Do you mean you are editing a card, removing an old audio file, and then adding a new one? And then reviewing that card in the standard study mode?

  4. 4 Posted by Andrew Vaughan on 22 Jun, 2020 07:12 AM

    Andrew Vaughan's Avatar

    Hi Damien,

    I'm having the same issue as above. I've made a deck of and recorded my answer as a mp3. The flashcard the shows the play button for the audio, but doesn't play the audio, even when the play button is played.

    I am using the 2.1.26 version for the mac. I am using a MacBook Air (13-inch, Early 2015) with MacOS Mojave version 10.14.6.

    Any pointers or tips on how to fix the issue would be very welcome.

    Many thanks


  5. Support Staff 5 Posted by Damien Elmes on 22 Jun, 2020 11:11 PM

    Damien Elmes's Avatar

    Hi Andrew,

    The original report was an issue with recording permissions. If the audio played when you originally recorded the sounds, then it sounds like you have a different issue. Does restarting your computer help?

  6. 6 Posted by Andrew Vaughan on 23 Jun, 2020 09:48 AM

    Andrew Vaughan's Avatar

    This comment was split into a new discussion: Anki 2.1.24: Recording not working on macos

    Hi Damien,

    Thanks very much for your quick response. I've restarted my computer and tried again and unfortunately the audio still doesn't play. I've checked the microphone and it is definitely on and working, with the volume on full. I tested with a new slide as follows: 1. Clicked on "Add", 2. Wrote "Test" on the front and the back and recorded "test", which shows as [sound:rec1592905489.mp3] typed into the front of the card, 3 then I press "add" to save the card. However, when the card comes up the audio doesn't play (although the audio file icon is showing on the card). It's very strange and I'm not sure what it could be. Other files that I have downloaded from other sources with audio work fine.

  7. 7 Posted by Andrew Vaughan on 24 Jun, 2020 07:22 AM

    Andrew Vaughan's Avatar

    Hi Damien,

    Thank you for your patience, that was exactly what the issue was. It works fine now.

    All the best


Comments are closed, but you can start a new discussion.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac