Anki 2.1.22 Bug: Closing does not end process

Louis's Avatar


27 Mar, 2020 10:52 AM

When sync to AnkiWeb on close is enabled, the Anki 2.1.22 anki.exe process does not terminate after sync. It remains visible in task manager, and when attempting to open a new instance of Anki, the error message "Anki Already Running" is displayed. Reinstalling did not fix the issue. Reinstalling and disabling sync on open/close does fix the issue (but then requires manual sync).
I also have backups enabled, and haven't tested whether this plays a role.

  1. Support Staff 1 Posted by Damien Elmes on 28 Mar, 2020 03:36 AM

    Damien Elmes's Avatar

    Please let me know if you can reproduce the problem using the latest beta:

  2. 2 Posted by Louis on 28 Mar, 2020 11:30 AM

    Louis's Avatar

    Hi Damien, I've downloaded the latest beta build (2.1.24beta2) and the problem persists as above - indeed it now seems to occur even with sync disabled.

  3. Support Staff 3 Posted by Damien Elmes on 29 Mar, 2020 09:10 AM

    Damien Elmes's Avatar

    Hi Louis,

    I can't seem to reproduce the problem here, even when automatic syncing is turned on. Do problems persist when you start Anki with the shift key held down to disable add-ons?

  4. 4 Posted by Louis on 04 Jun, 2020 06:55 PM

    Louis's Avatar

    Hi again, and many apologies for the absurdly delayed response, which is in fact a result of the fact that I was unable to reproduce the bug myself on a different machine, and the fact that it seems to have mysteriously disappeared on my original machine too. I assume it was ultimately the result of something wrong on my end. Thanks, and I hope this didn't cause too much inconvenience.

  5. Support Staff 5 Posted by Damien Elmes on 05 Jun, 2020 09:20 AM

    Damien Elmes's Avatar

    No problem, glad to hear the issue has gone away!

Comments are closed, but you can start a new discussion.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac