Adding sound to cards doesn't always work

Przemek's Avatar

Przemek

25 Jan, 2020 03:42 AM

Hi,

my problem is that I want my cards to make a sound when I use them. I followed instructions from this video https://www.youtube.com/watch?v=OqazNm3Re3U&lc=z223s3cjsvfzhntxp04t1aokgkx1postkje10nsrvlterk0h00410.1579838081517675 and it works like that (I even posted a comment with my problem but I didn't get any response). But it doesn't work when my type of cards is "Basic (type in the answer)". There just isn't any sound when I work with them - even though in previews there is and even though when the type of the card is just "Basic" there is.

Can any of you tell me how can I make it work?

  1. Support Staff 1 Posted by Damien Elmes on 25 Jan, 2020 11:35 PM

    Damien Elmes's Avatar

    Sounds inside a type in the answer field won't play, because that field is intended for typing. If you add the sound to a different field (creating one if necessary using the Fields button, and adding it to the card using the Cards button), then it should play correctly.

  2. 2 Posted by Przemek on 26 Jan, 2020 12:22 AM

    Przemek's Avatar

    Hi,
    thank you very much for the answer, you are right but when I added third field and added the sound there, the result is that when I am studying from these cards the sound is being played right after I see the front of the card (I attach below screenshots with settings that are currently used in this deck) BUT I would really want it to be like this:
    1. I see the front card with polish word (my native language) and below is empty blank to fill in with italian word which I am studying
    2. I write the italian word (right or wrong, doesn't matter)
    3. I click enter
    4. The sound of this italian word that I am supposed to write is played

    Is it possible? I attach my current settings of this deck.

  3. Support Staff 3 Posted by Damien Elmes on 26 Jan, 2020 08:58 AM

    Damien Elmes's Avatar

    If your goal is to play the sound when the back is shown, you need to add that field to the back template instead of the front one.

  4. 4 Posted by Przemek on 26 Jan, 2020 05:14 PM

    Przemek's Avatar

    Sorry, I am not sure how to do that... Can you explain it to me?

  5. Support Staff 5 Posted by Damien Elmes on 27 Jan, 2020 07:19 AM

    Damien Elmes's Avatar

    When you click Add Field, it gives you a choice of the Front or Back. Once you've added it to the back, you can remove {{third}} from the front.

  6. 6 Posted by Przemek on 27 Jan, 2020 08:26 AM

    Przemek's Avatar

    I've removed that third field, but now I am where I was at the beggining. I have 2 fields, the sound theoretically is in the second but in reality I don't hear it. I think I didn't really understand what you said, sorry. Could you maybe put it in another words?

    Now I've cleared my Anki, there are no my changes, new fields etc. If you could just tell me what I need to do that would be great. Sorry for problem.

  7. Support Staff 7 Posted by Damien Elmes on 27 Jan, 2020 09:39 AM

    Damien Elmes's Avatar

    If you're back at the beginning, please add the Field again from the Fields button, then use the Add Field button in the Cards screen, selecting the Back.

  8. 8 Posted by Przemek on 27 Jan, 2020 09:56 AM

    Przemek's Avatar

    I did what you said. Now it's like this. When I do the cards I immediately see both the word in my native language and the solution (of which audio btw. is played also immediately after opening the card...)

  9. Support Staff 9 Posted by Damien Elmes on 27 Jan, 2020 10:06 AM

    Damien Elmes's Avatar

    You added the Back field to the Front template. Instead, you need to add the Third field to Back template. To understand how the templates work, please see this intro video: http://www.youtube.com/watch?v=DnbKwHEQ1mA&yt:cc=on

  10. 10 Posted by Przemek on 27 Jan, 2020 10:37 AM

    Przemek's Avatar

    1. I created a new user (all the settings are cleared)
    2. I created a new deck "testing deck"
    3. I created third field with "Fields..." button
    4. In this testing deck I created 3 cards with type Basic (type in the answer).
    5. I opened "Cards..." button, then "Add Field", then picked Third Field, then I marked "Add to: BACK" and I clicked OK
    6. With these settings I created some cards with audio with the method in that youtube video that I linked in the first post.

    I wrote all this because I was thinking that again it's not going to work, but finally IT WORKED! Thank you my good man, you are extremely patient and nice. If someone is so dumb with Anki like me then you can take this step-by-step instruction.

    Thank you again and have a nice day! :)

  11. Support Staff 11 Posted by Damien Elmes on 28 Jan, 2020 08:43 AM

    Damien Elmes's Avatar

    Glad to hear you're up and running now :-)

Comments are closed, but you can start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac