Anki 2.1 won't play audio files with a blank in the title

Timo's Avatar


30 Dec, 2019 09:01 PM

Hey there,
I encounter the following problem after installing Anki Droid 2.1. (I deleted the previous version and then I installed 2.1.)

If I add an *.mp3 audio file to a new card, it will be played once upon dropping it. After saving the card, the audio won't be played again due to spaces in the title (also in preview mode). If there is no space in the title the audio file is played perfectly fine.
Using "tools - check media" the audio file won't be recognized as used in a card deck and therefore it will be deleted.
Audio files (with blanks) which were added in version 2.0 and before are still played perfectly fine. It only affects newly added audio files with spaces in the title after switching to Anki Droid 2.1.

Does anyone have a clue how to fix it?

Debug additional info:

Version 2.1.15 (442df9d6)
Qt 5.12.1 PyQt 5.11.3

Installed add-ons:
Deck Stats
Deck name in title 21
Mini Format Pack
Night Mode
Progress Bar
Progress Graphs and Stats for Learned and Matured Cards
Replay buttons on card
True Retention

Win 8.1 w/ current updates, 64 bit

  1. Support Staff 1 Posted by Damien Elmes on 30 Dec, 2019 09:39 PM

    Damien Elmes's Avatar
  2. 2 Posted by Timo on 07 Jan, 2020 10:10 AM

    Timo's Avatar

    Thx and sorry for the late reply.

    I did everything on the list. Nothing worked. The audio problem still exists.

    Actually it is no surprise to me. Nothing was changed on the system, except upgrading Anki from 2.0 to 2.1 by deinstalling the previous version first.
    To be quite frank I switched to 2.1 two times. So I switched back and forth once, due to the reason that Anki 2.1 didn't support the heatmap. In both cases I deinstalled first.

    Maybe I should make a brand new installation. But I am afraid I am losing all my own note types. Are they also stored in an export file?

  3. Support Staff 3 Posted by Damien Elmes on 07 Jan, 2020 09:24 PM

    Damien Elmes's Avatar

    Please point me to an example card in your collection that is exhibiting the problem.

  4. 4 Posted by Timo on 23 Jan, 2020 07:35 PM

    Timo's Avatar

    Hey there.

    I upgraded to the latest Anki version 2.1.19 on Win 8.1 and I encountered a serious error while synching.
    I decided to do a brand new installation of 2.1.19. Now everything works, except I still do have my audio file problem.

    I also installed that Anki version on a Win 10 Computer, synched it with my online account, and still have the audio file problem.

    For example:
    I download a mp3 from, when I paste it to a new card, the audio is played. After adding the card to the deck, the audio file won't be played while learning the card. The file will be erased after clicking tools -> check media. It is telling me the audio file is not used by any card (which is not true). Same happens on Win 10 Notebook.

    There is a work around though. If I use the file "l'ours <m>.mp3" the file will be erased because there is a space in the name. If I change it to "l'ours_<m>.mp3" the file works and will NOT be erased. I guess I have no choice and the moment and do it like this. It is illustrated in the picture.

  5. Support Staff 5 Posted by Damien Elmes on 24 Jan, 2020 08:19 AM

    Damien Elmes's Avatar

    I have not been able to reproduce the problem here - if I had a sound file with spaces, the file plays correctly and is not reported as missing. Are you manually typing the sound tags into your cards? If so, you may be accidentally adding non-breaking spaces. What exactly does it say when you use the media check?

  6. 6 Posted by Timo on 25 Jan, 2020 11:21 AM

    Timo's Avatar

    First of all thank you for your quick reply.

    Now I finally understand the problem. The difference is not a single space between characters in the file name. The problem occurs if I have more than one space in a row. If I drop the audio file on a new card, all the spaces in a row will be reduced to just one space. So in my case the three spaces in the file name will be reduced to just one, hence the problem with not finding it in the folder.

    At the end of the file names I usually add a tag like “Ff1” as an abbreviation for “forvo female 1” with a distance of three spaces in a row to the words or sentences I am learning.

    e.g. “le ménage Ff1.mp3”

    So I add “le ménage Ff1.mp3” to the card I am creating and it is instantly shown on the card like this “[le ménage Ff1.mp3]” already missing the three spaces (now it is just one). In the folder the file is saved with three spaces “le ménage Ff1.mp3”.

    If you now take a look at the picture I added, you can see the message I am getting when I apply “tools -> check media”. This totally makes sense. Due to the fact that the file in the folder is “le ménage Ff1” and the file name on the card says “le ménage Ff1”.

    I also tried changing the name on the card back to three spaces manually “le ménage Ff1”, but it still won’t work.

    Now I am going to change it to “le ménage – Ff1” and it will work perfectly fine.

    You should be able to reproduce this behavior in Anki. I also applied it to the shift mode without add ons and I am getting the same results.

    Thanks a lot for your help!

  7. Support Staff 7 Posted by Damien Elmes on 26 Jan, 2020 09:13 AM

    Damien Elmes's Avatar

    Thanks for the extra detail, this should be fixed in the next beta release.

Comments are closed, but you can start a new discussion.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac