"Failed to execute script runanki" when attempting to launch Anki

John's Avatar


21 Nov, 2019 04:36 AM

Good evening. After installing a new addon to Anki 2.1.15 (64-bit), I was no longer able to launch Anki. When trying to launch, it provides an error popup (see attached). Further, when trying to launch via Anki-Console, I receive a "ModuleNotFoundError: No module named 'pwd' error and the same "Failed to execute script runanki" error (also see attached).

I tried uninstalling Anki and reinstalling but the problem has persisted. What can I do to fix this?

  1. 1 Posted by John on 21 Nov, 2019 04:56 AM

    John's Avatar

    Update: I am unsure of which step fixed the problem, but it is fixed now. In order, I uninstalled Anki 2.1.15, installed Anki 2.1.11, then restarted the computer. Upon reboot the problem was fixed.

    I've since reinstalled Anki 2.1.15 and all seems well so far.

  2. Support Staff 2 Posted by Damien Elmes on 21 Nov, 2019 09:44 PM

    Damien Elmes's Avatar

    Based on a previous user report, it sounds like it's an issue caused by a Windows update, and restarting/upgrading fully seems to fix it.

  3. 3 Posted by benjjaa.skiiber on 22 Dec, 2019 04:42 PM

    benjjaa.skiiber's Avatar

    I found that allowing Anki to "Run this program as an administrator" fixed the issue. I didn't have to install any previous versions or update Windows etc.

  4. Support Staff 4 Posted by Damien Elmes on 23 Dec, 2019 02:54 AM

    Damien Elmes's Avatar

    That should not be necessary - it sounds like something is strange with your system's configuration.

  5. 5 Posted by user on 26 Jan, 2020 01:53 PM

    user's Avatar

    Allowing Anki to "Run this program as an administrator" works for me.

  6. 6 Posted by Akash on 03 Apr, 2020 07:40 AM

    Akash's Avatar

    Having the same issue on 2.1.22. Tried re-installing and problem persists.

    Allowing Anki to "Run this program as an administrator" works for me as well.

  7. 7 Posted by PabloLav on 13 Jun, 2020 01:30 PM

    PabloLav's Avatar

    Hi! I had the same problem. Executing the software as an administrator worked for me too.

Comments are closed, but you can start a new discussion.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac