Invalid HTML on card: ReferenceError: anki is not defined

alexis.coolidge's Avatar


02 Nov, 2019 10:57 PM


I have been using a large anki deck for >1 month, and cards that were previously working now give me this error message"Invalid HTML on card: ReferenceError: anki is not defined". I tried disabling addons but that did not help.

  1. Support Staff 1 Posted by Damien Elmes on 03 Nov, 2019 12:00 AM

    Damien Elmes's Avatar

    It sounds like you or a shared deck author has disabled fading in away that has broken display on the computer version. Please see the manual for code that is compatible with the computer version and AnkiMobile:

  2. 2 Posted by alexis.coolidge on 03 Nov, 2019 12:27 AM

    alexis.coolidge's Avatar

    Thank you!

  3. 3 Posted by alexis.coolidge on 03 Nov, 2019 03:47 AM

    alexis.coolidge's Avatar

    Hey Damien,

    The person who shared the deck with me had disabled the fade away function using some instructions you gave them a few days ago:


    Just wanted to check--do I need to put this code into my anki now to solve my error problem? The person you gave this code to runs on anki 2.0. Somehow having downloaded one of their decks with this line of code in it seems to have messed up that deck and my previous decks to give me the error message I listed above.


  4. Support Staff 4 Posted by Damien Elmes on 03 Nov, 2019 11:01 PM

    Damien Elmes's Avatar

    My initial reply to that post had code that was specific to AnkiMobile, but I fixed that when updating the manual, and provided your template code matches that in the manual, it should work correctly.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac