Error message: "Exception: Anki requires a UTF-8 locale."

Thomas's Avatar

Thomas

02 Nov, 2019 02:04 PM

Installed anki-2.1.15-linux-amd64 on a fresh install of Kubuntu 19.10 and received this:

Traceback (most recent call last):
  File "runanki", line 3, in <module>
  File "<frozen importlib.bootstrap>", line 971, in _find_and_load
  File "<frozen importlib._bootstrap>", line 955, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 665, in _load_unlocked
  File "/home/dae/Local/py512/lib/python3.6/site-packages/PyInstaller-3.5.dev0+g42af697-py3.6.egg/PyInstaller/loader/pyimod03_importers.py", line 631, in exec_module
  File "aqt/init.py", line 4, in <module>
  File "<frozen importlib._bootstrap>", line 971, in _find_and_load
  File "<frozen importlib._bootstrap>", line 955, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 665, in _load_unlocked
  File "/home/dae/Local/py512/lib/python3.6/site-packages/PyInstaller-3.5.dev0+g42af697-py3.6.egg/PyInstaller/loader/pyimod03_importers.py", line 631, in exec_module
  File "anki/init_.py", line 11, in <module>
Exception: Anki requires a UTF-8 locale.
[1731] Failed to execute script runank
Thank you.
  1. 1 Posted by Thomas on 02 Nov, 2019 02:12 PM

    Thomas's Avatar

    Sorry, I posted to early. The fix is:

    export LC_CTYPE=XX_YY.UTF-8 where XX and YY is your "locale" e.g. en_US or similar. Run "locale" to check.

  2. 2 Posted by Thomas on 02 Nov, 2019 02:13 PM

    Thomas's Avatar

    *too

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac