Bold/italics/underline affect browser search

josdanfnt's Avatar

josdanfnt

02 Nov, 2019 11:53 AM

Hello everyone! This is my first question in this forum. I hope I'm following all the rules :)

I have a problem regarding browse reaching in the Anki Windows app. If a word has some letters in bold, italics or if they are underlined, the browser doesn't recognize this letters as part of the word and if I were to enter the whole word in the search bar, it doesn't appear on the results. For example, if I have the word "Anki" in one filed, but write it as "Anki<b>ki</b>", and then enter "Anki" in the search bar, this note doesn't appear in the results, unless the word "Anki" without boldface appears in another field.

I know this problem might be due my lack of knowledge about HTML, but, do you guys know the solution? Thank you in advance :)

  1. Support Staff 1 Posted by Damien Elmes on 02 Nov, 2019 10:11 PM

    Damien Elmes's Avatar

    Anki is only able to ignore formatting in the sort field: https://apps.ankiweb.net/docs/manual.html#searching

  2. 2 Posted by josdanfnt on 02 Nov, 2019 10:27 PM

    josdanfnt's Avatar

    Thanks for the answer :)
    Well, the field I'm having the problem in is the sort field :( I'll be more specific: I'm having this problem with my Mandarin Chinese notes. Since differencing between "n" and "ng" is difficult for me, I decided to use bold for words with "ng" and underline words with "n", only formatting the coda ("ng" or "n"). However, when I enter "néng" in the search box I don't get results for "né<b>ng</b>", even though the pinyin field is my sort field.

    I think the solution is to simply use boldface or underline for the whole syllable instead of just the coda. But that won't fix the problem if I look up words like "yóu yǒng", since I won't get results for "yóu <b>yǒng</b>"

  3. Support Staff 3 Posted by Damien Elmes on 02 Nov, 2019 10:37 PM

    Damien Elmes's Avatar

    It's working for me:

  4. 4 Posted by josdanfnt on 03 Nov, 2019 02:17 PM

    josdanfnt's Avatar

    For some reason, it's now working for me as well... I think I found the problem: when the "Ignore accents" add-on is activated, «zhō<b>ng</b>» isn't recognized as «zhōng», but when I deactivate it, the problem is solved.

    Thanks for your time :)

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac