Failed to execute script runanki! fatal error.

ginny Snyder's Avatar

ginny Snyder

31 Oct, 2019 09:16 PM

Windows 10, reloaded anki, still get this fatal error "failed to execute scrpit runanki" help please

  1. Support Staff 1 Posted by Damien Elmes on 31 Oct, 2019 10:34 PM

    Damien Elmes's Avatar
  2. 2 Posted by Jan on 14 Nov, 2019 07:06 PM

    Jan's Avatar

    Downloaded standard Windows Version 2.1.15
    I just bought a new computer & have been trying to install Anki. I'm getting the same "failed to execute" error. I tried running using command prompt as suggested. In Program Files (x86) I got the "failed to execute" message. Nothing happened when I changed to x86 folder because that's not where it installed...
    And this...I still had download for version 2.1.12. I figured I'd just install from it so I copied it over to new machine. I got the same error on that install. This is still working on my older computer (up-to-date Windows 10).
    Just tried current alternate. Another fail...

  3. Support Staff 3 Posted by Damien Elmes on 14 Nov, 2019 08:38 PM

    Damien Elmes's Avatar

    It just says 'failed to execute' with no other text/information?

  4. 4 Posted by thejwstrunk54 on 14 Nov, 2019 10:40 PM

    thejwstrunk54's Avatar

    From: Damien Elmes <[email blocked]>
    Sent: Thursday, November 14, 2019 3:38 PM
    To: [email blocked]
    Subject: Re: Failed to execute script runanki! fatal error. [Anki (Computer Version) #36628]

    Sorry I didn’t include… Thanks.

  5. Support Staff 5 Posted by Damien Elmes on 15 Nov, 2019 12:32 AM

    Damien Elmes's Avatar

    On a normal Windows machine, the USERNAME environmental variable should be set to your username. It seems to be missing/blank on your machine. If you post on a Windows help forum, they may be able to give you a suggestion on how to resolve the issue.

  6. 6 Posted by Jan on 15 Nov, 2019 12:43 PM

    Jan's Avatar

    Thanks for your help, Damien.
    I ran this from Command Prompt this morning to get info for use in Windows help forum. I have no idea why, but... It installed.
    I don't know if this would make any difference. I think I had installed all available Windows updates prior to the last time I tried the install yesterday, I may be mistaken.
    Great program!

  7. Support Staff 7 Posted by Damien Elmes on 15 Nov, 2019 08:53 PM

    Damien Elmes's Avatar

    Glad to hear you're up and running now :-)

  8. 8 Posted by thaiscristalbre... on 04 Dec, 2019 03:04 AM

    thaiscristalbressan's Avatar

    Hi - I've tried installing the most up to date version, the older beta versions as linked here. Have also tried running the cmd prompt and still get the same 'failed to execute' error message.

    Not sure what else I can try. I've attached the cmd prompt screenshot

  9. Support Staff 9 Posted by Damien Elmes on 05 Dec, 2019 05:22 AM

    Damien Elmes's Avatar

    Please ensure all Windows updates are installed, restart your computer, and then try again.

  10. 10 Posted by Someone who had... on 17 Dec, 2019 08:39 AM

    Someone who had an issue's Avatar

    Hey, I had the same issue, but I managed to solve it.

    For me, all I needed was to update windows. You know "that" update, the one which you always set back by saying "remind me later" indefinitly? It turns out that that update is important.

    Damien knows his stuff.

    Update windows, it might help!

    Hope it helps!

  11. 11 Posted by Oyin on 09 Jan, 2020 03:19 PM

    Oyin's Avatar

    Hello, I’m having the same issue of getting this “failed to execute script runanki” message when I try to open my app on my windows computer. I’ve tried running the command prompt but it’s not giving me results. Please any help would be great. Thanks!

  12. 12 Posted by Oyin on 09 Jan, 2020 03:26 PM

    Oyin's Avatar

    Hello again, I'm attaching my command prompt screenshot

  13. Support Staff 13 Posted by Damien Elmes on 09 Jan, 2020 09:41 PM

    Damien Elmes's Avatar

    The top line you typed is invalid. After the second line you typed, you need to type

    anki-console

    on another line and then hit enter.

  14. 14 Posted by Oyin on 10 Jan, 2020 12:14 AM

    Oyin's Avatar

    Oh, thanks for the correction!
    I tried it that way and it gave me the following results, please see the attached screenshot.

  15. Support Staff 15 Posted by Damien Elmes on 11 Jan, 2020 09:50 PM

    Damien Elmes's Avatar

    That indicates you have the same problem as the people above, and need to ensure all updates are installed and your machine restarted.

  16. 16 Posted by Oyin on 13 Jan, 2020 09:39 PM

    Oyin's Avatar

    I installed an optional windows update and now it’s working. Thanks for the help, Damien!

  17. 17 Posted by AgusP on 14 Jan, 2020 01:05 AM

    AgusP's Avatar

    Hello, I have been dealing with similar issues when trying to use Anki on my PC. First, it wouldn't install. I'd get an error message (NSIS Error) reading 'Error launching installer'
    So I tried installing it on my brother's computer and there was no problem there, I copied all the files to a flashdrive and transferred then to my PC. Then when I try starting anki.exe, I get another error (Fatal error detected) reading 'Failed to execute script runanki'. Lastly I tried running ankiconsole.exe using the command prompt, I'm attaching a screnshot of what I'm getting there.
    At some point when I tried opening anki.exe nothing happened, no error, no nothing. And found out the process was being automaticalle terminated using the task manager. Now I just get the fatal error thing when trying that though.
    If there's anything I could do besides formatting my PC I'd be happy to know

  18. Support Staff 18 Posted by Damien Elmes on 14 Jan, 2020 05:34 AM

    Damien Elmes's Avatar

    The message seems to indicate Anki is missing some of its files, perhaps because they were not fully copied, were moved elsewhere by your antivirus, or are failing to load due to some quirk specific to your system.

Comments are closed, but you can start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac