IBus / Anthy not working

moonkid's Avatar

moonkid

23 Oct, 2019 10:52 AM

I am still doing diganosis on this problem.

Does anyone experience problems when typing japanese (via IBUS or IMEI) in Anki (e.g. creating new cards)?

In my setup (Debian 10, 64bit, XFCE desktop, IBUS+Anthy) am not able to type Japanese.
All other applications working fine BUT only JabRef is another application not working.
Maybe they use similiar libraries in the back?

  1. 1 Posted by mvf on 23 Oct, 2019 03:26 PM

    mvf's Avatar

    Someone had this issue a while back on Void Linux, although it was never reproduced or root-caused. You could check my comments in this GitHub issue [1] for a first diagnosis step and report the results here. Does it work in other Qt applications?

    [1] https://github.com/void-linux/void-packages/issues/2794

  2. Support Staff 2 Posted by Damien Elmes on 23 Oct, 2019 11:36 PM

    Damien Elmes's Avatar
  3. 3 Posted by moonkid on 24 Oct, 2019 02:33 AM

    moonkid's Avatar

    Thank you very much for that hint. The reporter of the bug never gave feedback if it was fixed or not.

    My ibus plugin is loaded as the diagnosis steps indicate

    https://github.com/void-linux/void-packages/issues/2794#issuecomment-545713899

    I also tried this diagnosis steps with JabRef. The grep output is empty there but I am not suprised about it because JabRef is Java not using Qt.

  4. 4 Posted by mvf on 24 Oct, 2019 08:35 AM

    mvf's Avatar

    Thanks, Damien, for the relevant link (and for fixing my bugged posts, not sure why they wouldn't show).

    So this issue seems to only occur on Debian for now. They introduced a security fix for ibus that triggers a race in glib, breaking the IME for some applications. Qt and Java seem to be using ibus in a similar way, so it broke for both.

    Some of your options, from least to most painful:

    - Downgrade/pin ibus
    - Switch to another IME, e.g. fcitx
    - Build glib yourself with the proposed patch and hope for the best

    FWIW, I can confirm that fcitx-anthy is working with Anki on Debian bullseye, although I use fcitx-mozc as a daily driver.

  5. 5 Posted by moonkid on 02 Nov, 2019 04:31 AM

    moonkid's Avatar

    Side information:
    On Debian 10 some modifications where done and JabRef works again witih ibus-anthy. But Anki (2.1.15) still not working.

    https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=941018

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac