IndexError: list index out of range , crashes immediately with Starup Error

trentonbullock's Avatar

trentonbullock

14 Oct, 2019 11:15 AM

Getting this error when I attempt to load Anki. It crashes immediately. I'm using Linux Mint 19.2

Please notify support of this error:

Traceback (most recent call last):
  File "/usr/share/anki/aqt/__init__.py", line 230, in run
    _run()
  File "/usr/share/anki/aqt/__init__.py", line 300, in _run
    mw = aqt.main.AnkiQt(app, pm, opts, args)
  File "/usr/share/anki/aqt/main.py", line 44, in __init__
    self.pm.load(self.pm.profiles()[0])
IndexError: list index out of range

  1. Support Staff 1 Posted by Damien Elmes on 14 Oct, 2019 10:44 PM

    Damien Elmes's Avatar
  2. 2 Posted by trentonbullock on 15 Oct, 2019 06:39 PM

    trentonbullock's Avatar

    None of this helps because the program crashes on open.

  3. Support Staff 3 Posted by Damien Elmes on 16 Oct, 2019 12:23 AM

    Damien Elmes's Avatar

    The error you're getting should not occur in recent Anki versions, so that seems to indicate you are not running the latest version.

  4. 4 Posted by trentonbullock on 16 Oct, 2019 12:26 AM

    trentonbullock's Avatar

    Is 2.1.15 the latest version?

  5. Support Staff 5 Posted by Damien Elmes on 16 Oct, 2019 12:57 AM

    Damien Elmes's Avatar

    It is, but you may have an old version lying around, as the error you pasted indicates you're running from a source install and not the packaged version of Anki.

  6. 6 Posted by trentonbullock on 17 Oct, 2019 05:39 PM

    trentonbullock's Avatar

    Can you help me?

    I tried uninstalling but can't get it to work.

  7. 7 Posted by trentonbullock on 17 Oct, 2019 05:51 PM

    trentonbullock's Avatar

    I also tried install from packaged version, still doesn't work.

  8. Support Staff 8 Posted by Damien Elmes on 18 Oct, 2019 06:40 AM

    Damien Elmes's Avatar

    Please remove the /usr/share/anki folder, then try the packaged version again. If you get an error message, please paste it here.

  9. 9 Posted by trentonbullock on 18 Oct, 2019 08:42 AM

    trentonbullock's Avatar

    *I verified /usr/share/anki folder was deleted.   then..*

    sudo apt-get install anki

    *Still getting Error below *

    Please notify support of this error:

    Traceback (most recent call last):

    File "/usr/share/anki/aqt/__init__.py", line 230, in run

    _run()

    File "/usr/share/anki/aqt/__init__.py", line 300, in _run

    mw = aqt.main.AnkiQt(app, pm, opts, args)

    File "/usr/share/anki/aqt/main.py", line 44, in __init__

    self.pm.load(self.pm.profiles()[0])

    IndexError: list index out of range

    **

    *On command line anki --version*

    anki 2.1.0beta36

  10. 10 Posted by trentonbullock on 18 Oct, 2019 09:06 AM

    trentonbullock's Avatar

    I tried install package from here. https://launchpad.net/ubuntu/+source/anki

    Got the error below.    Now trying to figure out how to update
    python3-pyqt5.      My version is 5.10, and i have the latest version of
    Linux Mint 19.2

  11. Support Staff 11 Posted by Damien Elmes on 18 Oct, 2019 10:23 PM

    Damien Elmes's Avatar

    Please use the build directly from the Anki website.

    Third party Linux packages and source builds are not supported

  12. 12 Posted by trentonbullock on 19 Oct, 2019 08:47 AM

    trentonbullock's Avatar

    Damien,

    This is what I originally used and could not get to work.  I was only
    when I couldn't get the builds off of the Anki website to work I started
    to look for other alternatives.

  13. Support Staff 13 Posted by Damien Elmes on 19 Oct, 2019 11:28 PM

    Damien Elmes's Avatar

    Please remove the /usr/share/anki folder, then install the packaged version from the Anki website. If you still get an error message, please paste it here.

  14. 14 Posted by trentonbullock on 20 Oct, 2019 06:44 PM

    trentonbullock's Avatar

    We actually went through this exercise already.   But I can it again if
    you like.

    $ tar xjf Downloads/anki-2.1.15-amd64.tar.bz2
    $ cd anki-2.1.15-linux-amd64
    $ sudo make install

    This is the error I get.

    $ anki

    qt: qglx_findConfig: Failed to finding matching FBConfig (8 8 8 0)
    qt: qglx_findConfig: Failed to finding matching FBConfig (1 8 8 0)
    qt: qglx_findConfig: Failed to finding matching FBConfig (1 1 8 0)
    qt: qglx_findConfig: Failed to finding matching FBConfig (1 1 1 0)
    qt: qglx_findConfig: Failed to finding matching FBConfig (1 1 1 0)
    qt: qglx_findConfig: Failed to finding matching FBConfig (8 8 8 0)
    qt: qglx_findConfig: Failed to finding matching FBConfig (1 8 8 0)
    qt: qglx_findConfig: Failed to finding matching FBConfig (1 1 8 0)
    qt: qglx_findConfig: Failed to finding matching FBConfig (1 1 1 0)
    qt: qglx_findConfig: Failed to finding matching FBConfig (1 1 1 0)
    qt: No suitable graphics backend found

    Received signal 6
    #0 0x7f64d2ceda4f <unknown>
    #1 0x7f64d2cede4b <unknown>
    #2 0x7f64d2cee4ce <unknown>
    #3 0x7f64ef571f20 <unknown>
    #4 0x7f64ef571e97 gsignal
    #5 0x7f64ef573801 abort
    #6 0x7f64e9862dcc QMessageLogger::fatal()
    #7 0x7f64d11f701c <unknown>
    #8 0x7f64d11f683f <unknown>
    #9 0x7f64d1781c72 <unknown>
    #10 0x7f64d3b1150c <unknown>
    #11 0x7f64d52dcbb3 <unknown>
    #12 0x7f64d2cc7745 <unknown>
    #13 0x7f64d2cfaa10 <unknown>
    #14 0x7f64eec486db start_thread
    #15 0x7f64ef65488f clone
       r8: 0000000000000000  r9: 00007f645fffe860 r10: 0000000000000008 r11:
    0000000000000246
      r12: 00007f6458002880 r13: 0000000000003cb6 r14: 00007f645fffee10 r15:
    00007f64580024b0
       di: 0000000000000002  si: 00007f645fffe860  bp: 00007f645fffebc0  bx:
    00007f6458002880
       dx: 0000000000000000  ax: 0000000000000000  cx: 00007f64ef571e97  sp:
    00007f645fffe860
       ip: 00007f64ef571e97 efl: 0000000000000246 cgf: 002b000000000033 erf:
    0000000000000000
      trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
    [end of stack trace]
    Calling _exit(1). Core file will not be generated.

  15. Support Staff 15 Posted by Damien Elmes on 20 Oct, 2019 11:49 PM

    Damien Elmes's Avatar

    You say 'already', but it's the first time you've posted that specific error message. Please see https://anki.tenderapp.com/discussions/ankidesktop/34554-instalatio...

  16. 16 Posted by trentonbullock on 21 Oct, 2019 12:51 AM

    trentonbullock's Avatar

    That did it.  Thank you sir!!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac