Filtered decks

Ivo's Avatar

Ivo

09 Oct, 2019 04:06 PM

Hello,

I've faced a problem with filtered decks (attached image). It is that search box successfully finds tagged cards, filtered - not. I intentedly removed all other criteria but whatever I add didn't change the result. The problem is *only* with this tag. I checked even ASCII values to confirm that tag and search criteria use the same letters. Other tags seem to work correctly.

I even tried to remove the tag, rebuilt DB and create it again - same result.

I'll appreciate any comments, ideas and help.

Thank you
Ivo

  1. Support Staff 1 Posted by Damien Elmes on 09 Oct, 2019 11:26 PM

    Damien Elmes's Avatar
  2. 2 Posted by Ivo on 10 Oct, 2019 07:28 AM

    Ivo's Avatar

    Hi Damien,

    Thank you for your fast reply. Actually, this was the place where I started. Then I read all the searching section and then googled the problem and read the messages here. Unfortunately, I didn't find a solution and this is why I posted this message with a picture, believing that a picture worth 1000 words.

    The search is simple, nothing fancy, just tag with a word, no special characters.

    But it seems not to work in Filtered decks, regardless it does in search box. Documentation as I understood says that both are the same.... I cannot understad what is the problem and hope someone smarter than me to help me with this.

    Thank you

  3. 3 Posted by Vit on 11 Oct, 2019 02:19 AM

    Vit's Avatar

    @Ivo:
    I encountered this problem in 2013.
    It was recommended to always verify the search string in the Browser.

  4. Support Staff 4 Posted by Damien Elmes on 11 Oct, 2019 05:59 AM

    Damien Elmes's Avatar

    "Filtered decks can not pull in cards that are suspended, buried, or already in a different filtered deck. And unless you are using the experimental scheduler, they can not pull in cards that are in (re)learning. For this reason, a search in the browser may reveal cards that don’t end up in the filtered deck."

    The cards in your screenshot are in learning or buried.

  5. 5 Posted by Ivo on 11 Oct, 2019 09:28 AM

    Ivo's Avatar

    Thank you, Damien,

    The card is indeed in learning. I'll dig further in this.

    @Vit:
    This is what I did and the result is puzzling for me, because in the browser card exists, in filtered deck - not. The only reason that might explain this behaviour is the one Damien pointed out - it is in learning.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • filtered_decks.jpg 277 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac