Also Anki on my phone. ALL MY PICTURES ARE GONE

Ryan Fitzner's Avatar

Ryan Fitzner

18 Aug, 2018 03:39 PM

So I have a huge med school test on monday and i get up this morning to start studying and ALL 230 of my pictures associated with my notecards are GONE.

For some time now they have only showed up as question marks on my computer, but have always been as pictures on my phone, I dont like studying from my computer, so I didn't think it was any big deal, but now my phone only has little boxes where the pictures should be too. I cant find the pictures in my media folder, where did they all go. and why is it for the last few weeks none of my pictures have been showing up on my computer, or saving to the media folder where they should be? There are some random ones saved there, but very few, why is it randomly choosing, to me it makes sense it should be all or nothing, not partial.

I am kinda crappin bricks over here.

I tried the media check and it says things are missing, where are all my pictures or backups with them?

Please help promptly. Its a huge test!!!!

  1. 1 Posted by Ryan Fitzner on 18 Aug, 2018 03:41 PM

    Ryan Fitzner's Avatar

    Also: i went to my media folder and there are just a few pictures from all my decks, so they aren't there. Even all the pictures I used for MCAT study are hit and miss and I backed up that file ages ago.

  2. Support Staff 2 Posted by Damien Elmes on 19 Aug, 2018 02:24 AM

    Damien Elmes's Avatar

    Hi Ryan,

    You appear to have synchronized around 40 deletions today, so if you're unable to locate those 40 images in your recycle bin, please let me know and I can restore them from an AnkiWeb backup:
    Sound/image media files have gone missing!

  3. 3 Posted by Ryan Fitzner on 19 Aug, 2018 02:27 PM

    Ryan Fitzner's Avatar

    So, im not sure what 40 have gone away, but as i studied throughout the day
    I realized that when I study the card there is no picture showing, just a
    white box on my phone, and since the beginning a little box with a question
    mark inside on my computer. On my phone if I hit edit, the picture pops up.
    So I think it might just be a glitch, and not my pictures all being gone
    like I thought. But no matter what they won't show up on my computer. As
    for the 40 cards, is it possible to put them in another deck or something,
    because my overall notecard count of 366 seems about right.

  4. Support Staff 4 Posted by Damien Elmes on 20 Aug, 2018 07:37 AM

    Damien Elmes's Avatar

    Hi Ryan,

    Ok, the problem is you have image data embedded in your fields, perhaps from pasting with HTML stripping turned off. You can make these images visible again by:

    1. Downloading Anki 2.1.2 from the website and installing it: https://apps.ankiweb.net/docs/changes.html#changes-in-anki-2.1
    2. Downloading this add-on, which I have updated today: https://ankiweb.net/shared/info/1293255374
    3. Selecting all cards in the Browse screen, then using Notes>Localize Images

    Anki 2.1 will automatically ensure future images you paste are handled properly.

  5. 5 Posted by Ryan Fitzner on 22 Aug, 2018 01:23 AM

    Ryan Fitzner's Avatar

    So I did as you said, now I get this error every time I try to open it up
    on my computer

    An error occurred. Please use Tools > Check Database to see if that fixes
    the problem.

    If problems persist, please report the problem on our support site
    <https://help.ankiweb.net>. Please copy and paste the information below
    into your report.

    Anki 2.1.2 Python 3.6.1 Qt 5.9.6 PyQt 5.9.2

    Platform: Windows 10

    Flags: frz=True ao=False sv=1

    ----------------------------------------

    Exception happened during processing of request from ('127.0.0.1', 59364)

    Traceback (most recent call last):

    File "socketserver.py", line 639, in process_request_thread

    File "socketserver.py", line 361, in finish_request

    File "socketserver.py", line 696, in __init__

    File "http\server.py", line 418, in handle

    File "http\server.py", line 406, in handle_one_request

    File "aqt\mediasrv.py", line 67, in do_GET

    File "aqt\mediasrv.py", line 85, in send_head

    ValueError: _isdir: path too long for Windows.

    Also my phone still doesn't show images.

  6. Support Staff 6 Posted by Damien Elmes on 22 Aug, 2018 07:29 AM

    Damien Elmes's Avatar

    Hi Ryan,

    Haven't seen this one before - is your Windows user name quite long? Are you using the default User 1 profile in Anki, or have you created a different profile name? If you type %APPDATA% in the Windows file browser location bar and hit enter, what is the resulting text?

    You should be able to revert to Anki 2.0.52 for now, but it would be good to get to the bottom of what's causing 2.1 not to work for you.

  7. 7 Posted by Ryan Fitzner on 22 Aug, 2018 03:05 PM

    Ryan Fitzner's Avatar

    My windows user name is "Ryan Fitzner" and yes i'm under user 1. I put the
    %APPDATA% in and here are 2 screenshots of what came up. The first one
    shows the anki, and the second is what shows when I click on it.

  8. 8 Posted by Ryan Fitzner on 22 Aug, 2018 03:12 PM

    Ryan Fitzner's Avatar

    So just to clarify, every time I go to a window in anki on my computer
    desktop app it doesn't work. It works if the notecard doesn't have
    pictures, but if there is a picture the error message shows up, I can
    ignore it and then I get access to my notecard minus the pictures.
    Pictures work on ankiweb
    Pictures show up as boxes as I review notecards (like on my computer) on my
    phone, but when I click on edit, they will show up in the edit screen with
    no issue, they also can be viewed if I search them in browse mode.

    So no pictures on computer
    Pictures always on ankiweb
    Pictures on phone only if I am in edit or browse.

    I uninstalled and reinstalled anki on my phone, but I haven't done it on my
    computer.

  9. 9 Posted by Ryan Fitzner on 22 Aug, 2018 06:27 PM

    Ryan Fitzner's Avatar

    Update: Now when I try to copy and paste an image the app crashes on
    desktop. Its really weird, I literally was going through a lecture, copy
    and pasting, then all of a sudden it just started dying every time I try to
    copy something in, even images that I already had copied in before without
    an issue.

  10. Support Staff 10 Posted by Damien Elmes on 23 Aug, 2018 06:45 AM

    Damien Elmes's Avatar

    Hi Ryan,

    I suspect the first issue you reported is due to some files with long file names in your media folder. If you double click on User 1 in your second screenshot, then collection.media, if there are a couple of files with long names you could try temporarily moving them out of the folder.

    Regarding the crashes, do they persist after restarting your computer? Do you use a third party clipboard manager?

  11. 11 Posted by Ryan Fitzner on 23 Aug, 2018 02:07 PM

    Ryan Fitzner's Avatar

    All the images in that folder actually work, I didn't know that they worked
    on my computer, I don't study on my computer just my phone, that's why I
    checked a few on my computer. I don't know where all the other images are.
    there are only about 80 images in that folder and by now I should have
    275-300 total in all my decks. I have 3 decks, and there are images from
    each deck in there.

    for the crash I don't use a clipboard manager, just control c and v. I
    didn't try to restart, I just reverted to 2.0.52.

    Thanks for all your help!

  12. Support Staff 12 Posted by Damien Elmes on 24 Aug, 2018 01:54 AM

    Damien Elmes's Avatar

    You still have about 200 images inlined in your cards, which indicates that the steps I provided in post #4 have not yet been successfully performed. If you repeat the process, what does it say in the resulting message box when you perform step 3?

  13. 13 Posted by Ryan Fitzner on 29 Aug, 2018 04:48 PM

    Ryan Fitzner's Avatar

    Sorry, I forgot to inform you when I tried to download that add on I get an
    error message (attached in screen shot), I have successfully downloaded
    another add on just last week, so my computer can handle using the add-ons.
    I had a card I wanted to reset the scheduling on. I downloaded that add on
    with no issues and used it.

     So yeah you are correct, I haven't been able to perform the actions in
    your 4th post.

    Ryan

  14. Support Staff 14 Posted by Damien Elmes on 30 Aug, 2018 01:59 AM

    Damien Elmes's Avatar

    You are using Anki 2.0.52 - as mentioned in step 1, you'll need to install Anki 2.1.

  15. 15 Posted by Ryan Fitzner on 30 Aug, 2018 11:05 PM

    Ryan Fitzner's Avatar

    Sorry I'm a technological ignoramuse, again you're right, it says right at
    the top of the add on that it only works with anki 2.1.

    That finally worked! all my images are working correctly!

    Thanks for all the work you do. I really appreciate your help, this app,
    and how effective it makes me. I gladly paid 25 for the app and would pay
    10 times that amount for how helpful it has been.

    Thanks again

    Ryan

  16. Support Staff 16 Posted by Damien Elmes on 31 Aug, 2018 05:23 AM

    Damien Elmes's Avatar

    Glad to hear that's resolved the issue :-)

  17. 17 Posted by Ryan Fitzner on 12 Nov, 2018 07:04 PM

    Ryan Fitzner's Avatar

    Greetings Damien! hope all is well

    Just a quick little question. So I was looking in my anki deck today for a
    single notecard and I KNEW it contained the word venoconstriction. I went
    about searching for it and it didn't pop up at all. I was confused, and
    thought about other words that were on the card, thinking I had misspelled
    it. I eventually find the card and I discover in order to emphasize the
    importance of venoconstriction I had written the word *veno*constriction.
    The bolded *veno* in the word made it not pop up in "venoconstriction "
    search.

    I thought that was weird but tested it out, and sure enough, if I bold part
    of a word it doesn't show up in the search. However, if I bold the whole
    word it shows up fine in my search. I often partially bold words because my
    studies involve many similar topics that need a positive or negative
    qualifier or have other qualifier words, and am worried about my inability
    to find them and refresh my memory since the partially bolded word is often
    the only one that is unique enough for me to remember in my search to
    narrow down my deck of 1500 note cards or so. Is there a setting or
    something I can do for the search to ignore this formatting issue?

    Thanks so much

    Ryan Fitzner

  18. Support Staff 18 Posted by Damien Elmes on 13 Nov, 2018 05:54 AM

    Damien Elmes's Avatar

    Hi Ryan,

    This is a limitation of Anki's current database format - it can only ignore text formatting in the first field.

  19. 19 Posted by Ryan Fitzner on 14 Nov, 2018 05:34 PM

    Ryan Fitzner's Avatar

    Ok Thank you!

  20. 20 Posted by Ryan Fitzner on 27 Jul, 2019 07:16 PM

    Ryan Fitzner's Avatar

    Good afternoon,

    I am currently trying to figure out how to run two anki profiles at the
    same time. I have a monster deck of 20,000+ cards, that I want to browse
    study, and add certain ones to my Deck that I currently use.

    I scrounged reddit to find out how to do it, and I found this in your
    manual, but it hasn't been working for me.

    Let me now take this opportunity to say I have no clue about how computers
    work, they are magic to me. I can only ever figure out any computer issues
    if there is a step by step tutorial on how to do it. I looked high and low
    for one and I can't find it. So here I am bothering you. so anyway, heres
    the instructions I tried to follow.

    Running from a Flash Drive

    On Windows, Anki can be installed on a USB / flash drive and run as a
    portable application. The following example assumes your USB drive is drive
    G.

       -

       Copy the \Program Files\Anki folder to the flash drive, so you have a
       folder like G:\Anki.
       -

       Create a text file called G:\anki.bat with the following text:

    g:\anki\anki.exe -b g:\ankidata

    If you would like to prevent the black command prompt window from remaining
    open, you can instead use:

    start /b g:\anki\anki.exe -b g:\ankidata

       -

       Double-clicking on anki.bat should start Anki with the user data stored
       in G:\ankidata.

    I followed all the steps, but I placed it in my additional Hard drive (D:/)
    just cause I thought it would be more like having an external drive from my
    C drive, and my computer might not recognize it as the same program. I have
    a C, drive and a D drive. So I replaced the two g:\ to d:\. But when I try
    to open the text file, it just literally opens the file where I have pasted
    the "start /b d:\anki\anki.exe -b d:\ankidata"

    I did run into the problem where it says to create a text fil called
    G:\anki.bat, but it doesn't let me use : or \ in a file name. So I took
    that to mean that I put the anki.bat text file in my D:\ drive, so if i
    were to locate it the file name would be called D:\anki.bat.

    I included screen shots of my D: drive and where I pasted the anki program
    file into, then I have one of my opened anki program to make sure it's the
    right one, then I have one of the anki.bat file.

    What did I do wrong?

    Thanks

    Ryan Fitzner

  21. Support Staff 21 Posted by Damien Elmes on 27 Jul, 2019 11:23 PM

    Damien Elmes's Avatar

    I'm afraid this is not something Anki was designed for. You'll need to either use the switch profile option to switch between the profiles, or run the other copy of Anki as a separate Windows user.

  22. 22 Posted by Jacob Misra on 25 Sep, 2020 03:57 PM

    Jacob Misra's Avatar

    This comment was split into a new private discussion: Also Anki on my phone. ALL MY PICTURES ARE GONE

    Hi Damien,

    I hope this finds you well. My 'Clickable tags' add-on has not been working since I updated to AnKing v7. I'm presently using AnKing v8 and I have the latest version of Clickable tags installed (v2.0). Is there a way to tweak things that would show the tags at the bottom of the screen?

    Clickable Tags v2.0 (Anki 2.1.20+ support) - AnkiWeb

    I was reading the comments on the add-on page and one of the users said,
    "Not working with 2.1.

    Edit: Worked after this change.

    Had to change <div id="tags-container">{{Tags}}</div> to <div id="tags-container">{{clickable::Tags}}</div>."

     I'm not savvy with CSS and couldn't make sense of it. I tried looking in the card styling and couldn't find <div id="tags-container">{{Tags}}</div>

    I tried checking on my new AnKing v8 profile and it doesn't work on that profile. I have attached screenshots below. Please let me know what I can do to fix this issue.

    Thank you!

    Very Respectfully,

    Jacob

Comments are closed, but you can start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac