Image Occlusion Enhanced [Official thread]

Glutanimate's Avatar

Glutanimate

13 Oct, 2016 12:25 AM

This is the new official support thread for Image Occlusion Enhanced (old thread). From now on please direct all of your questions about the add-on here.

Thank you!

Showing page 9 out of 9. View the first page

  1. 241 Posted by Bucay on 18 Feb, 2020 02:04 PM

    Bucay's Avatar

    I was trying to add some new image occlusion, I could add 400 new cards but now it stopped working and always this error occurs. Please help. I already reinstalled it

  2. 242 Posted by Anon on 20 Feb, 2020 05:00 PM

    Anon's Avatar

    Hi,
    Unfortunately in this alpha version of Image Occlusion, the path masking tool has a bug in it and no longer functions. When an attempt is made to use it, a blue dot appears in the middle of the picture and the application freezes.

    Any help resolving this bug would be greatly appreciated.

  3. 243 Posted by Arthur on 28 Feb, 2020 01:40 PM

    Arthur's Avatar

    Hello! I really like the add-on but I´m having a lot of troubles, I can´t export images to my desk and also I can´t draw the path and even the rectangles stop working. Can I use any other version? I just need that, please I need it so much to help me with my exams

  4. 244 Posted by G on 05 Mar, 2020 03:45 PM

    G's Avatar

    Thanks for your awesome add-on,

    How to modify the size of the very first picture pasted onto the Image Occlusion Enhanced instead of the second one imported onto the first picture??

  5. 245 Posted by char on 10 Mar, 2020 06:53 AM

    char's Avatar

    Thanks for developing this add-on which sounds so promising but I'm unable to use it on my Anki. I'm using the latest version of Anki (checked it by redownloading it from the website) and the Image occlusion enhanced alpha for anki 2.1.

    I followed all the instructions in the Youtube tutorial (as you can see in my screenshots) but the masks do not appear at all in the cards created. Please help :(

  6. 246 Posted by Glutanimate on 10 Mar, 2020 02:36 PM

    Glutanimate's Avatar

    @char: Please try renaming the "Image Occlusion Enhanced" note type to something random, then restart Anki. This will create a new "Image Occlusion Enhanced" note type with everything reset to the defaults. Please check if you can create occlusions with that, and let me know if you're still seeing issues.

    *Please note that renaming the old note type will make any existing occlusions you have created under that note type non-editable. They will continue to work fine in the reviewer , however (if they worked before).

  7. 247 Posted by Glutanimate on 10 Mar, 2020 02:41 PM

    Glutanimate's Avatar

    @everyone reporting issues with the path tool / error messages popping up when creating cards:

    Right now the path tool and some other more advanced features of the masks editor are broken. For that reason my suggestion would be to stick to rectangles, simple lines, and text labels for now. I know that this is a bit more limiting, but you should be able to cover most use cases using these tools. E.g., to cover up a larger irregular-shaped area, you could draw multiple rectangles, select them all with shift+click, and then group them using "G".

    It's not an easy fix, but I'm working on addressing the problems with the other tools. Hopefully everything should work fine again in the next (stable) release of the add-on.

  8. 248 Posted by char on 11 Mar, 2020 05:46 AM

    char's Avatar

    Hi, thanks for getting back to me so quickly! I tried your suggestion (see screenshot) but the issue described in my first post persists.

    Please let me know if you need any further information from me. Thanks so much in advance. Look forward to hearing from you.

  9. 249 Posted by Glutanimate on 11 Mar, 2020 06:29 AM

    Glutanimate's Avatar

    @char:

    I think you ended up renaming the card type rather than the note type. You can rename the note type by heading to Tools → Manage Note Types.

    However, looking at your card templates, it seems like the issue is that the mask overlay field is missing from them. This might have happened by accident while customizing the templates

    The most surefire way to fix this would be to rename the note type as mentioned above and start over with a stock note type. However, if you feel up to fixing the issue manually:

    Find the line that says <div id="io-overlay></div> in both the Front Template and Back Template, and replace it with <div id="io-overlay">{{Question Mask}}</div> on the front template and <div id="io-overlay">{{Answer Mask}}</div> on the back template.
    However, there is no guarantee this will fix everything as there might be more modifications lurking in other parts of the template.

    In the future the add-on will come with a button to reset the templates to the defaults, so things like this should become much easier to fix. I'm also planning on adding some warnings and other protections that make it more difficult to modify the templates by accident.

    Hope this helps for now!

  10. 250 Posted by AMLark on 12 Mar, 2020 03:00 AM

    AMLark's Avatar

    I have trouble downloading the image occlusion add on. I recently downloaded Anki 2.1 and it says

    One or more errors occurred:

    1374772155: Invalid code, or add-on not available for your version of Anki.

    Please help. Thank you very much :)

  11. 251 Posted by char on 12 Mar, 2020 06:02 AM

    char's Avatar

    Dear developer,

    Thank you so much for being so responsive and so helpful with all my issues with this awesome add-on. Extremely glad to tell you that the issue has been resolved and I'm excited to see how this add-on can enhance my med revision!

    Thank you so much!

  12. 252 Posted by Cynk on 14 Mar, 2020 11:39 AM

    Cynk's Avatar

    Same thing as @Buckay posted. It's second time already.
    What can I do???

    Caught exception:
    Traceback (most recent call last):
      File "aqt/webview.py", line 368, in handler
      File "/Users/cynk/Library/Application Support/Anki2/addons21/1374772155/add.py", line 278, in <lambda>
        lambda val, choice=choice, close=close: self._onAddNotesButton(choice, close, val))
      File "/Users/cynk/Library/Application Support/Anki2/addons21/1374772155/add.py", line 293, in _onAddNotesButton
        r = gen.generateNotes()
      File "/Users/cynk/Library/Application Support/Anki2/addons21/1374772155/ngen.py", line 80, in generateNotes
        (svg_node, layer_node) = self._getMnodesAndSetIds()
      File "/Users/cynk/Library/Application Support/Anki2/addons21/1374772155/ngen.py", line 190, in _getMnodesAndSetIds
        mask_doc = minidom.parseString(self.new_svg.encode('utf-8'))
    AttributeError: 'NoneType' object has no attribute 'encode'

  13. 253 Posted by nas on 21 Mar, 2020 06:14 PM

    nas's Avatar

    I am new to anki. I mistakenly deleted some of the default fields in Anki image occlusion Enhanced. Now each time i want to use the IO, it gives me this error message.
    " Error; image occlusion note type not configured properly. Please make sure you did not manually delete or rename any of the default fields"

    i have gone through resetting note type and template to the defaults but it still wouldn't work. The new Note type i created is not in the same order as the default
    I need your assistance.
    Thank you

  14. 254 Posted by Glutanimate on 26 Mar, 2020 05:31 PM

    Glutanimate's Avatar

    @char:

    Thank you for the kind words! Happy I could help and happy everything worked out!

    @AMLark:

    Hmm, could you install the latest version of Anki 2.1 and try again? You can grab it here: https://apps.ankiweb.net/#download

    @Cynk:

    Please see my comment here: https://anki.tenderapp.com/discussions/add-ons/8295-image-occlusion...

    @nas:

    Hmm, did you follow the troubleshooting steps here: https://github.com/glutanimate/image-occlusion-enhanced/wiki/Troubl...

    Those should normally yield a functioning note type. (Sorry BTW that this is so complex, in the future I'm planning on automating the note type restoration process).

    If that doesn't work, a very simple solution might be to just rename your existing Image Occlusion Enhanced note type to something else. The add-on should then generate a brand new note type once you restart Anki / use IO again for the first time. This won't help with editing any existing IO cards you have created, but it would at least allow you to create new cards again.

    Hope that helps for now!

  15. 255 Posted by Zac on 06 Apr, 2020 05:40 AM

    Zac's Avatar

    Hi all,

    I just started Anki and whenever I accidentally pressed Esc button editing my image occlusion enhanced window, my work gets deleted without warning.
    Is there a way to stop this from happening?

    Thank you.

  16. 256 Posted by John on 21 Apr, 2020 06:36 PM

    John's Avatar

    Hello,

    I have made a couple of Image Occlusion Enhanced cards for used Anki Web and they work perfectly fine. When viewing the same cards on Ankidroid I am met with an empty image screen. They only thing that shows is the yellow occlusion cards. I have attached pictures of examples below.

    I have tested several things so far:
    1) The image does appear in the Windows location: C:\Users\User\AppData\Roaming\Anki2\User 1\collection.media

    2) The images actually appear on the mobile version but only when I go to "Edit Note" the card, go to down to "Image" and click on the paper clip next to it which takes me to the page "Editing Field". So the data is there, it just won't show where I need it to.

    3) I have uninstalled and reinstalled Ankidroid

    The mobile phone I am using is OnePlus 7T Pro if that helps. Ideally I'd like to have the mobile version work so that I can revise on the go.

  17. 257 Posted by Florie on 01 May, 2020 05:46 PM

    Florie's Avatar

    Hello,

    Thank you so much glutaminate for making this awesome add-on! However, I´m having the same trouble with post 256. I really want to using this add-on as I think it will really help with decreasing the time on making flashcards and more on revising them. When I´m revising my image occluded flashcards the initial card has the Image and the Question Mask, however when I click on "Show answer" the image disappears and its leaving me with only the Answer Mask.

    I have tried to delete and re-download the add-on multiple times, but it didn´t solve the problem. However, one card worked out just fine, but the rest of it all are like this. What should I do?

  18. 258 Posted by Pratik on 01 May, 2020 09:16 PM

    Pratik's Avatar

    I am using this add-on and finding it very useful. Up until a couple of days ago, when I wanted to add a picture for image occlusion I would choose the image occlusion note type and then copy and paste the picture into the image section of it (figure 1). I would then click on the top right hand green button for Image occlusion and it would direct me towards the image occlusion screen. However recently, after pasting the image on the image section, when I click the top right hand button, instead of taking me to the image it is taking me to my files to pick another image (figure 2). Is this due to an update or has there been any changes in what I am doing?

  19. 259 Posted by german.jablo on 06 May, 2020 11:50 PM

    german.jablo's Avatar

    https://github.com/Glutanimate/image-occlusion-enhanced/wiki/Troubleshooting#transparencyopacity-settings-dont-seem-to-apply-to-masks

    Hello! I have modified line 61 of ngen.py as indicated in this link, but all I can do is put transparencies in "Original mask". I still can't put transparent "Question mask" ... which is what really has a utility. Any ideas how can I solve this?

    EDIT (SOLVED): I was able to accomplish that by also removing rows 380 and 382 from ngen.py

  20. 260 Posted by ossicle on 08 May, 2020 08:17 PM

    ossicle's Avatar

    Thank you so much for all of your hard work Glutanimate!

    I've encountered a problem where I can't seem to get fields to hide in edit mode (even the default [Extra 1,Extra 2] fields are displaying, despite being correctly excluded in the IO settings.) I've rolled all changed to the card's layout back to the defaults as listed in the troubleshooting guide. I've also renamed the note type to something random to re-generate a stock IO note type, but the issue persists. Uninstalling/reinstalling the add-on (and Anki itself) have not fixed the problem either.

    Any suggestions would be greatly appreciated!

  21. 261 Posted by ankiuser on 12 May, 2020 12:23 PM

    ankiuser's Avatar

    Hello,
    This addon used to fit the images to the screen but now big images requires scrolling.
    Des anyone know how to restore the previous behavior?

  22. 262 Posted by nicholas.d.rodw... on 13 May, 2020 07:56 AM

    nicholas.d.rodwell's Avatar

    With Image Occlusion Enhanced for Anki 2.1 (alpha) i have to manually right click hit copy and then right click to paste an image occlusion square because ctrl+C ctrl+V doesnt seem to be working, there is no shortcut is bracket next to the option when i right click either.

    See attached screenshot
    Any solutions?

  23. 263 Posted by Jansen on 10 Jun, 2020 09:53 AM

    Jansen's Avatar

    Is anyone using this with digital hand written cards? I am trying to, for equations and diagrams, it's just easier to write than to type, and probably also better for retention.

    I'm trying to figure out the easiest workflow to do this. I want to make the cards on my iPad and review them on my iPhone, with any necessary deck management on my Mac.

    Any recommendations for apps or workflows that minimise the time it takes to get an image from the iPad app to Anki, and that also allows easy editing later on (in case of mistakes for example)?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac