Speed Focus Mode stopped working

hy's Avatar


30 Apr, 2020 03:16 AM

Speed Focus Mode Add-on stopped working after updating add-ons. I'm using anki 2.1. Is there a way to resolve this?

  1. 1 Posted by Glutanimate on 30 Apr, 2020 06:10 PM

    Glutanimate's Avatar


    Sorry to hear that. From the sounds of it another add-on likely broke Speed Focus Mode in some way. SFM hasn't undergone any changes recently, so I assume that one of the other add-ons that were updated now conflict with it.

    To get to the bottom of this it would be super helpful if you could post your Anki debug info. You can find it by going to Anki → About (or Help → About if you're on Windows), and then clicking on "Copy debug info". If you can, please paste that info as a reply to this thread. That should make it easier to find out which other add-on could be conflicting.

  2. 2 Posted by speedfocus on 03 May, 2020 03:24 PM

    speedfocus's Avatar

    Anki 2.1.23 (de9543ff) Python 3.8.0 Qt 5.13.1 PyQt 5.14.1
        Platform: Mac 10.15.4
        Flags: frz=True ao=True sv=2
        Add-ons, last update check: 2020-05-02 22:59:32
        ===Add-ons (active)===
        (add-on provided name [Add-on folder, installed at, version, is config changed])
        Clickable Tags v20 Anki 2120 support ['1739176371', 2020-03-28T17:45, 'None', '']
        Heatmap ['1722241614', 2019-11-13T14:43, 'None', '']
        Hierarchical Tags 2 ['594329229', 2020-04-11T12:36, 'None', '']
        HoochiePapa Randomize New Queue ['1173108619', 2020-04-24T23:17, 'None', '']
        Leaderboard ['41708974', 2020-05-02T06:11, 'None', mod]
        More Overview Stats 21 ['738807903', 2020-02-03T10:25, 'None', '']
        Pop-up Dictionary beta ['153625306', 2019-09-24T20:50, 'None', '']
        Removes Empty Note Types for 21 ['530953383', 2020-01-27T00:59, 'None', '']
        Special Fields ['1102281552', 2020-03-28T19:58, 'None', mod]
        Speed Focus Mode auto-alert auto-reveal auto-fail ['1046608507', 2019-06-02T05:11, 'None', '']
        True Retention ['613684242', 2017-11-19T15:43, 'None', '']
        ===IDs of active AnkiWeb add-ons===
        1046608507 1102281552 1173108619 153625306 1722241614 1739176371 41708974 530953383 594329229 613684242 738807903
        ===Add-ons (inactive)===
        (add-on provided name [Add-on folder, installed at, version, is config changed])

  3. 3 Posted by speedfocus on 03 May, 2020 03:25 PM

    speedfocus's Avatar

    mine for some reasons also stopped working

  4. 4 Posted by Glutanimate on 03 May, 2020 04:19 PM

    Glutanimate's Avatar


    Thanks for the report & debug info. I tried replicating your setup, add-ons and all, but I haven't been able to reproduce the issue on my end. Everything works fine over here

    Please check if the cards you're reviewing actually have the correct options group set up. SFM's settings are tied to individual deck options, so if you're reviewing cards with a different deck options group, the settings won't apply.

    (This seems to be the most common point of confusion with the add-on.)

  5. 5 Posted by dj on 17 May, 2020 03:43 AM

    dj's Avatar

    Hi Glutanimate
    Speed Focus Mode Add-on stopped working for me too after updating add-ons. I'm using anki 2.1 as well (I use a mac). I updated image occlusion and hoochie mama addons (I have deleted both as thought they may be the problem) and now still have the same problem. This problem occurred so I updated anki to 2.1.26 (was on 2.1.23 when the problem occurred) but that did not fix the problem. I only regularly use one deck (all cards in one deck) so I know that isn’t the problem that is occurring here.
    I normally use the Anking speed focus mode (with the pause button feature), and when I delete it and restart the same problem occurs. I have deleted this addon and tried the Glutanimate speed focus mode (without the pause button feature), and the same problem occurs.
    So I download speed focus mode, alert.mp3 is outside the sounds folder, so there is no sound initially. I moved it into sounds folder. This is what I did initially when I got the addon ages ago and everything worked fine. Now what happens is as I am doing the cards, I set the sound to go off at 7 seconds, with card reveal at 12 seconds. After I have done a few cards, the sound lags, and goes off at say 10 seconds. Then eventually, after a few cards, I click good on a card, it sort of lags/pauses before going to next card. After this, the addon is broken and does not work at all. I still get the notification but I do not get any sound. I have tried reinstalling the addon, using Anking/Glutanimate addon and same thing happens. Note, the issue is the sound only once it has been moved into the sounds folder.
    Is there a way to fix this? Thanks so much for your help. I have attached my debug info below.

        Anki 2.1.26 (70784154) Python 3.8.0 Qt 5.13.1 PyQt 5.14.1
        Platform: Mac 10.14.6
        Flags: frz=True ao=True sv=1
        Add-ons, last update check: 2020-05-17 10:59:24
        ===Add-ons (active)===
        (add-on provided name [Add-on folder, installed at, version, is config changed])
        Frozen Fields ['516643804', 2020-03-01T12:12, 'None', '']
        Hierarchical Tags 2 ['594329229', 2020-04-12T00:36, 'None', '']
        ImageResizer ['1214357311', 2019-02-28T08:17, 'None', '']
        Minimal Flat Big Buttons compatible with ReMemorize Buttons ['1042429613', 2020-03-11T19:09, 'None', '']
        More Overview Stats 21 ['738807903', 2019-01-06T04:42, 'None', '']
        Review Heatmap ['review_heatmap', 2020-04-30T21:23, 'None', '']
        Speedfocus (auto good and pause) ['Speedfocus', 0, 'None', '']
        True Retention by Card Maturity ['923360400', 2017-08-30T03:00, 'None', '']
        ===IDs of active AnkiWeb add-ons===
        1042429613 1214357311 516643804 594329229 738807903 923360400
        ===Add-ons (inactive)===
        (add-on provided name [Add-on folder, installed at, version, is config changed])

  6. 6 Posted by Medi.Cin on 05 Jun, 2020 02:23 PM

    Medi.Cin's Avatar

    I just figure out every time I am using the Add On: _Advanced Review Bottom Bar, I can't use the Speed Focus Mode. Please help @Glutanimate

  7. 7 Posted by Noodlz on 06 Jun, 2020 04:06 AM

    Noodlz's Avatar

    I am also facing a similar problem, the addon doesnt respect the time that has been set in the configuration. The card plays alert earlier and shows answer earlier than the time set, also when the rate again is set to 0, the card auto fails.

  8. 8 Posted by Glutanimate on 06 Jun, 2020 12:30 PM

    Glutanimate's Avatar


    I appreciate the detailed bug report! Unfortunately it's very difficult to troubleshoot when there are so many different influencing factors at play. To simplify things, please do the following for me:

    1. Uninstall the version of SFM you currently have installed (which looks to be an unofficial version, AnKing or otherwise)
    2. Disable all other add-ons.
    3. Restart Anki
    4. Install SFM from AnkiWeb: https://ankiweb.net/shared/info/1046608507
    5. Restart Anki
    6. Please create a new deck and name it "SFM", then add a few random basic cards to the deck.
    7. Go into the deck options of the "SFM" deck, click on "Manage" in the top right, then "Add" in the dropdown menu. Enter "SFM" as the new deck options group name, then click on "OK". The prompt should close and you should see "SFM" selected as the deck options group at the top of the deck options window. Now click on "Restore Defaults" to ensure that the default options are used.
    8. Head to the "General" tab of the deck options window and enter the following: Automatically play alert after 7 seconds. Automatically show answer after 12 seconds. Please leave everything else as is. Click on "OK" to confirm your choices and return to Anki's main screen.
    9. Please head into the newly created "SFM" deck and now check if the settings you've configured in the previous step work, i.e. whether an alert plays after 7 seconds and whether the answer is shown after 12 seconds.

    The idea behind these steps is to confirm whether the add-on works properly on your stock Anki installation with no other things interfering (unofficial version of the add-on, other add-ons, modified deck options, etc.).

    I know that this is a lot, but it would make my life around a hundred times easier as I have not been able to reproduce the issue on any of my test setups.

    Once we've figured out that things work in this stock configuration, we can then go ahead and see what is at fault for the issues you see when you're not using a stock configuration.


    Advanced Review Bottom Bar completely overwrites a part of Anki that SFM relies on, so I'm afraid that any fix would have to be done on Advanced Review Bottom Bar's part. ARBB's bug tracker is here: https://github.com/noobj2/Anki-Advanced-Review-Bottombar/issues. Additional means of contact might be listed on the add-on's AnkiWeb page: https://ankiweb.net/shared/info/1136455830


    Please make sure that the cards you are reviewing are actually using the deck options group where you've set up your settings. The settings are specific to each deck options group, so if you are reviewing cards that use different options groups, they will be treated differently by the add-on.

    Also: It looks like one of you guys downvoted the add-on on AnkiWeb while referring to this thread. If you are reading this, I would very much appreciate it if you could remove your downvote.

    Troubleshooting issues like this takes time and is not easy. For the majority of users the add-on works fine, and to find out why it might not work properly in specific cases is very difficult as there a myriad of different factors that could be at play: Hundreds of other add-ons that could interfere, weird card templates that prevent the add-on from working, options that are not set up properly. Add to that the fact that there are now unofficial versions of the add-on circulating that I have no control over, and I hope you can see how difficult of a task all of this is.

    I'm happy to help to find out what's wrong, but leaving a downvote to get my attention is not OK. Given how ratings are calculated, that one single downvote wields an enormous power – and the same applies to other add-ons – so please use downvotes sparingly and only when they're truly called for.

    As I mention in the description in all of my add-ons:

    Please do not use reviews for bug reports or support requests. I don't get notified of your reviews, and properly troubleshooting an issue through them is nearly impossible. Instead, please either use the issue tracker (preferred), add-on support forums, or just message me at [email blocked]. Constructive feedback and suggestions are always welcome!

    Thank you.

  9. 9 Posted by dj on 07 Jun, 2020 02:20 AM

    dj's Avatar

    Hi @Glutanimate
    Cheers for the detailed troubleshooting procedure. There were no issues. I have attached the debug info. I also noticed this time when i downloaded the addon, alert.mp3 was located in the sounds file, so I didn't even have to move that. Would you rather me continuing to reply here, or to contact you some other way?
    Cheers :)

        Anki 2.1.26 (70784154) Python 3.8.0 Qt 5.13.1 PyQt 5.14.1
        Platform: Mac 10.14.6
        Flags: frz=True ao=True sv=1
        Add-ons, last update check: 2020-06-07 07:19:10
        ===Add-ons (active)===
        (add-on provided name [Add-on folder, installed at, version, is config changed])
        Speed Focus Mode auto-alert auto-reveal auto-fail ['1046608507', 2019-06-02T17:11, 'None', '']
        ===IDs of active AnkiWeb add-ons===
        ===Add-ons (inactive)===
        (add-on provided name [Add-on folder, installed at, version, is config changed])
        Frozen Fields ['516643804', 2020-03-01T12:12, 'None', '']
        Hierarchical Tags 2 ['594329229', 2020-04-12T00:36, 'None', '']
        Image Occlusion Enhanced for Anki 21 alpha ['1374772155', 2020-04-28T10:21, 'None', '']
        ImageResizer ['1214357311', 2019-02-28T08:17, 'None', '']
        Leaderboard ['41708974', 2020-05-31T01:15, 'None', mod]
        Minimal Flat Big Buttons compatible with ReMemorize Buttons ['1042429613', 2020-03-11T19:09, 'None', '']
        More Decks Stats and Time Left ['1556734708', 2020-04-01T04:19, 'None', '']
        More Overview Stats 21 ['738807903', 2019-01-06T04:42, 'None', '']
        Progress Graphs and Stats for Learned and Matured Cards ['266436365', 2020-03-29T14:26, 'None', '']
        Review Heatmap ['review_heatmap', 2020-04-30T21:23, 'None', '']
        True Retention by Card Maturity ['923360400', 2017-08-30T03:00, 'None', '']
        Wrapper meta-addon ['396502676', 2020-06-03T06:59, 'None', '']

  10. 10 Posted by Ali on 01 Jul, 2020 12:25 AM

    Ali's Avatar

    No need for a reply: but I had the same issue and was able to narrow it down to this addon. After disabling it fixed my problem.

    Extended Tag AddEdit Dialog

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac