Image Occlusion Enhanced not working

Moises's Avatar

Moises

26 Mar, 2020 09:34 AM

Im having trouble with using the image occlusion enhanced add-on.

Did some occlusion squares on the image and also some lines and arrows to link the words and the occlusion boxes in the image, but nothing else (no more edition than that).
After finishing with the image and the cards I want to make, when I try to add the cards by clicking on the options Hide one or Hide all, a message of error pops up (see message below).

The only add-ons I have are:
- Image Occlusion Enhanced for Anki 21 alpha
- Review Heatmap (the original, by glutanimate I think, that I downloaded directly from the links people mentioned on the Review Heatmap add-on that is in the main page of the add-ons. Don't know if it is interfering with the Image Occlusion add-on)
 

This is the message that shows on the anki when I click on the options Hide one guess one, or Hide all guess one:

An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools > Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.
When you've discovered the add-on that is causing the problem, please report the issue on the add-on support site.

Error
An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools > Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.
When you've discovered the add-on that is causing the problem, please report the issue on the add-on support site.
Debug info:
Anki 2.1.22 (0ecc189a) Python 3.8.0 Qt 5.14.1 PyQt 5.14.1
Platform: Windows 10
Flags: frz=True ao=True sv=1
Add-ons, last update check: 2020-03-25 14:38:30

Caught exception:
Traceback (most recent call last):
  File "aqt\webview.py", line 446, in handler
  File "C:\Users\Moises Dell\AppData\Roaming\Anki2\addons21\1374772155\add.py", line 278, in <lambda>
    lambda val, choice=choice, close=close: self._onAddNotesButton(choice, close, val))
  File "C:\Users\Moises Dell\AppData\Roaming\Anki2\addons21\1374772155\add.py", line 293, in _onAddNotesButton
    r = gen.generateNotes()
  File "C:\Users\Moises Dell\AppData\Roaming\Anki2\addons21\1374772155\ngen.py", line 80, in generateNotes
    (svg_node, layer_node) = self._getMnodesAndSetIds()
  File "C:\Users\Moises Dell\AppData\Roaming\Anki2\addons21\1374772155\ngen.py", line 190, in _getMnodesAndSetIds
    mask_doc = minidom.parseString(self.new_svg.encode('utf-8'))
AttributeError: 'NoneType' object has no attribute 'encode'

I already tried to reinstall the Image Occlusion Enhanced. Don't know what to do next...

  1. 1 Posted by Glutanimate on 26 Mar, 2020 05:26 PM

    Glutanimate's Avatar

    Hey Moises,

    Sorry about the trouble with the add-on. I'm aware of the issue and working on a fix. Please see my comment here: https://anki.tenderapp.com/discussions/add-ons/8295-image-occlusion...

  2. 2 Posted by Moisés B Andrad... on 26 Mar, 2020 05:32 PM

    Moisés B Andrade's Avatar

    Hey man, if you are aware of the problem there are no worries! Thought the
    problem was with my computer or my anki (I'm new in this program).

    Anyways, keep up with the good work, looking forward to be using the next
    version of the add-on without problems.

    My best

    Moises

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac